Closed Bug 1686951 Opened 1 year ago Closed 11 months ago

Support switch-to-tab in Private Browsing windows

Categories

(Firefox :: Address Bar, task, P3)

task
Points:
3

Tracking

()

VERIFIED FIXED
91 Branch
Tracking Status
relnote-firefox --- 91+
firefox91 --- verified

People

(Reporter: mak, Assigned: daisuke)

References

Details

Attachments

(1 file)

Currently switch to tab is disabled in private windows, the reasoning is explained in bug 816527 and it boils down to the fact we don't want to confuse users in a private window sending them to a non private tab.

But, we can annotate tabs with their private status in our storage, and then have switch-to-tab partitioned by status, so PB windows only allow to switch to private tabs, and non-PB windows to non-private tabs. We are doing a similar partitioning with container ids too.

Points: --- → 3
Assignee: nobody → daisuke
Status: NEW → ASSIGNED
Attachment #9227326 - Attachment description: Bug 1686951: Support switc-to-tab in private browsing window. → Bug 1686951: Support switch-to-tab in private browsing window.
Pushed by dakatsuka.birchill@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/c64f61161cb8
Support switch-to-tab in private browsing window. r=adw
Regressions: 1717392
Status: ASSIGNED → RESOLVED
Closed: 11 months ago
Resolution: --- → FIXED
Target Milestone: --- → 91 Branch

I can confirm the switch-to-tab is now available in private window mode.
I verified using Fx 91.0a(2021-06-29) on Windows 10 x64, macOS 10.13 and Ubuntu 20.04 LTS.

Status: RESOLVED → VERIFIED

Hi, is that something worth mentioning in our beta release notes?

Flags: needinfo?(mak)

Why not, it sounds like something people may be interested into.

Release Note Request (optional, but appreciated)
[Why is this notable]: extending the switch tab feature to private browsing windows, this feature is appreciated by quite a few users, thus it may be worth pointing it out as an improvement
[Affects Firefox for Android]: nope
[Suggested wording]: The address bar now provides Switch to Tab results also in Private Browsing windows.
[Links (documentation, blog post, etc)]: none

relnote-firefox: --- → ?
Flags: needinfo?(mak)

Thanks, added to our beta release notes.

Duplicate of this bug: 1008577

Moving this question from the dupe here for visibility:

(In reply to Loreno Heer from bug 1008577 comment #6)

Any way to disable this again? This is extremely confusing and annoying. I prefer to have private and normal browsing to be strictly separated.

Drew/Daisuke, can you comment? comment #0 suggests that we shouldn't ever be offering switch-to-tab options for non-private windows in private windows and vice versa; did that get implemented?

Flags: needinfo?(daisuke)
Flags: needinfo?(adw)

Also maybe some added comment on why I think it is confusing. I regularly use the normal browsing mode for my private accounts (gmail, github, ..) and then use the private browsing for work related stuff (gmail, github, ...). So there ends up a lot of the same websites open but basically with different credentials. Then if I open a new tab and want to switch to gmail for example I expect this to be in the same context, otherwise it takes me to the other window or screen and scrolls the tabs around and I have to move back and rearrange everything...

Loreno, might you be seeing bug 1720369? That was fixed in 92 while the original bug was fixed in 91, so unfortunately there's one release, 91, where private and non-private tabs can be comingled WRT switch to tab.

Flags: needinfo?(helohe)
Flags: needinfo?(daisuke)
Flags: needinfo?(adw)
Regressions: 1720369

(In reply to Drew Willcoxon :adw from comment #11)

Loreno, might you be seeing bug 1720369? That was fixed in 92 while the original bug was fixed in 91, so unfortunately there's one release, 91, where private and non-private tabs can be comingled WRT switch to tab.

Ah that is perfect then. I am on 91 which I assume is the current release. If it is fixed in 92 that's great. Thanks a lot.

Flags: needinfo?(helohe)

This was included in the final 91.0 release notes.

(In reply to Loreno Heer from comment #12)

(In reply to Drew Willcoxon :adw from comment #11)

Loreno, might you be seeing bug 1720369? That was fixed in 92 while the original bug was fixed in 91, so unfortunately there's one release, 91, where private and non-private tabs can be comingled WRT switch to tab.

The fix for this was also included in the 91.0.1 release.

You need to log in before you can comment on or make changes to this bug.