Closed Bug 1687022 (win-nnt) Opened 8 months ago Closed 7 months ago

[meta] Disable native theme by default in Nightly on Windows

Categories

(Core :: Widget: Win32, task, P2)

task

Tracking

()

RESOLVED FIXED
88 Branch
Tracking Status
firefox88 --- fixed

People

(Reporter: spohl, Assigned: emilio)

References

(Regressed 1 open bug)

Details

(Keywords: meta, perf-alert)

Attachments

(1 file)

+++ This bug was initially created as a clone of Bug #1615105 +++

This bug is to track bugs that have to be addressed before non-native theming can be enabled by default in Nightly on Windows.

Depends on: 1657694
Depends on: 1615038
Depends on: 1619425
Depends on: 1657191
Depends on: 1621236
Depends on: 1680615

Tracking non-native theming bugs for Fission Beta milestone (M7).

Fission Milestone: --- → M7
Depends on: 1687152
No longer depends on: 1619425

Shipping NNT on Windows is not a Fission blocker.

Fission Milestone: M7 → ---
Depends on: 1694522
Depends on: 1694527
Depends on: 1694708
Depends on: 1694714
Depends on: 1694751
Depends on: 1694755
Alias: win-nnt
Depends on: 1695741
Depends on: 1695965
Depends on: 1695970

With the fixes on autoland + the fixes in your queue this should be green, so
let's try this.

Assignee: nobody → emilio
Status: NEW → ASSIGNED
Pushed by ealvarez@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/e2e3769604ef
Enable nnt on Windows Nightly by default. r=mstange
Pushed by emilio@crisal.io:
https://hg.mozilla.org/integration/autoland/rev/8e119693efa8
Menulist shrinkwrap test is a bit more fuzzy with swgl.
Pushed by emilio@crisal.io:
https://hg.mozilla.org/integration/autoland/rev/e5dca6404942
Whoops, update mozinfo so it picks nnt wpt annotations.
Pushed by emilio@crisal.io:
https://hg.mozilla.org/integration/autoland/rev/e223fa86737c
Make image-element widget test expectation lousy on win win7 since it passes in some configurations.

== Change summary for alert #29051 (as of Thu, 04 Mar 2021 08:31:40 GMT) ==

Improvements:

Ratio Suite Test Platform Options Absolute values (old vs new)
17% perf_reftest_singletons scrollbar-styles-1.html windows10-64-shippable-qr e10s stylo webrender 599.31 -> 496.23
16% perf_reftest_singletons scrollbar-styles-1.html windows10-64-shippable e10s stylo 581.24 -> 490.56
12% tabswitch windows10-64-shippable-qr e10s stylo webrender-sw 8.70 -> 7.62
12% tabswitch windows10-64-shippable-qr e10s stylo webrender 8.66 -> 7.60
9% tabswitch windows10-64-shippable e10s stylo 11.94 -> 10.84
6% a11yr dhtml.html windows10-64-shippable-qr e10s stylo webrender-sw 319.42 -> 300.07
6% a11yr dhtml.html windows10-64-shippable-qr e10s stylo webrender 318.54 -> 300.60
5% a11yr dhtml.html windows10-64-shippable e10s stylo 322.52 -> 306.31

For up to date results, see: https://treeherder.mozilla.org/perfherder/alerts?id=29051

Regressions: 1699650
Regressions: 1704297
Regressions: 1708560
Regressions: 1727289
You need to log in before you can comment on or make changes to this bug.