nsPSMDetector::HandleData takes about 1.1% of page load time

RESOLVED WONTFIX

Status

()

RESOLVED WONTFIX
16 years ago
9 years ago

People

(Reporter: dbaron, Assigned: jshin1987)

Tracking

({intl, perf})

Trunk
x86
Linux
intl, perf
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

I just ran a page load profile on a list of 40 live URLs on the web (see
attachment 88207 [details] for the approximate methods used).  In the profile I ran on a
2002-09-14 build, nsPSMDetector::HandleData (in mozilla/intl/chardet/src/) takes
about 1.1% of page load time.  In the profile I ran on a 2002-08-06 build, it
was not present at all.

There are a number of possibilities:
 * This is a recent regression
 * This is a problem only on uncached loads (and thus closer to 2% of uncached
loads, since I did two loops through my URL list)
 * This is a problem only on a specific page within the list of URLs (and thus
closer to 40% of the time for loading a single URL).
Keywords: perf
Created attachment 99227 [details]
profile of time spent within nsPSMDetector::HandleData

This is a segment of a profile that shows only the time spent within
nsPSMDetector::HandleData.
Hmmm.  So this doesn't show up in a clean profile.  Perhaps the problem is that
I was at one point a few weeks/months ago looking at a Japanese page that
required View | Character Coding | Auto Detect | Japanese, and that's been set
ever since.  Nevertheless, this seems like something that should be fixed even
if it isn't in the default profile.

Updated

16 years ago
Keywords: intl
QA Contact: ruixu → ylong

Comment 3

16 years ago
-> shanjian
Assignee: yokoyama → shanjian

Comment 4

14 years ago
shanjian is no longer working on mozilla for 2 years and these bugs are still
here. Mark them won't fix. If you want to reopen it, find a good owner first. 
Status: NEW → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → WONTFIX

Comment 5

14 years ago
Mass Re-assigning bugs that Frank Tang Closed on March 1st Spam is his fault

Mass Re-Open to follow
Assignee: shanjian → nobody

Comment 6

14 years ago
Mass Re-open of Frank Tangs Won't fix debacle. Spam is his responsibility not my own
Status: RESOLVED → REOPENED
Resolution: WONTFIX → ---

Comment 7

14 years ago
Reassigning Franks old bugs to Jungshik Shin for triage - Sorry for spam
Assignee: nobody → jshin1987
Status: REOPENED → NEW
QA Contact: amyy → i18n
Source file no longer exists (bug 426271)
Status: NEW → RESOLVED
Last Resolved: 14 years ago9 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.