loading in tabs stops when master password dialog pops up

RESOLVED DUPLICATE of bug 74331

Status

SeaMonkey
Tabbed Browser
RESOLVED DUPLICATE of bug 74331
16 years ago
10 years ago

People

(Reporter: ratman, Assigned: jag (Peter Annema))

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
using moz1.2a on winme, but this is an old problem.  this is quite possibly
being filed to the wrong component, so i apologize in advance.

the steps:
1 - open moz
2 - load a page that contains a login/password combination that is stored and
protected by the password manager
3 - before the page loads, quickly open a new tab
4 - in the new tab, quickly load any random page (most effective with large
pages with lots of content)
5 - before your first page loads, open yet another tab
6 - once again load any random page
7 - repeat steps 5 and 6 as desired, until
8 - the master password dialog pops up.  

expected results:
all of the pages load completely, and the first page awaits the password manager.

actual results:
the first page has presumably finished loading.  the last page will load to
completion only if the url has been resolved before the master password dialog
pops up.  otherwise, all other tabbed pages stop loading - prove this to
yourself by monitoring your data throughput.

Comment 1

16 years ago
I think this has more to do with the implementation of tabbed browsing than it
does with password manager.  Reassigning.  Send back if you think I'm wrong.

Reporter, can you demonstrate the problem with loading into other windows rather
than loading into other tabs?  If not, then it definitely is a tabbed-browser
problem.
Assignee: morse → jaggernaut
Component: Password Manager → Tabbed Browser
QA Contact: tpreston → sairuh
QA Contact: sairuh → pmac

Comment 2

16 years ago
A Related problem is that when using multiple tabs within one browser window if
one of the tabs requires HTTP Authorisation until you have entered your login
details either correctly or not you cannot switch to another tab. If the sites
are open in new windows you can do this.

If you know the login details this is not a problem, however if you need to look
them up, all the other tabs are blocked. This is especially annoying if you have
the login details open on another tab that you cannot switch to! You can cancel
the autorisation and then press back and retry, but if you want to copy and
paste the details from another page you are forced to use notepad etc to
temporarily hold the login and password.

Comment 3

14 years ago
I guess the dialog is modal, so it looks like a dupe of Bug 74331.
(Reporter)

Comment 4

14 years ago
seems that way.  i'll comment in there, and if it turns out to not be the case,
i'll undupe this.


*** This bug has been marked as a duplicate of 74331 ***
Status: NEW → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE
Product: Core → SeaMonkey
You need to log in before you can comment on or make changes to this bug.