Closed Bug 1687585 Opened 9 months ago Closed 9 months ago

Port bug 1632448 -Remove now unused confirm and extensionID parameters for nsISearchService.addEngine, and rename it to addOpenSearchEngine

Categories

(Thunderbird :: Upstream Synchronization, defect, P1)

Thunderbird 85

Tracking

(thunderbird_esr78 unaffected, thunderbird86+ fixed)

RESOLVED FIXED
87 Branch
Tracking Status
thunderbird_esr78 --- unaffected
thunderbird86 + fixed

People

(Reporter: bodqhrohro, Assigned: mkmelin)

References

Details

Attachments

(1 file)

User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:85.0) Gecko/20100101 Thunderbird/85.0

Steps to reproduce:

  1. Preferences → General → Default Search Engine → Add from file
  2. Picked a file with following contents:

<SearchPlugin xmlns="http://www.mozilla.org/2006/browser/search/">
<ShortName>DuckDuckGo</ShortName>
<Description>DuckDuckGo</Description>
<InputEncoding>UTF-8</InputEncoding>
<Image width="16" height="16">https://duckduckgo.com/favicon.ico</Image>
<Url type="text/html" method="GET" template="https://duckduckgo.com/">
<Param name="q" value="{searchTerms}"/>
</Url>
<SearchForm>https://duckduckgo.com</SearchForm>
</SearchPlugin>

Actual results:

Uncaught (in promise) TypeError: Services.search.addEngine is not a function
addSearchEngine chrome://messenger/content/preferences/general.js:701

Expected results:

The search engine successfully added.

Status: UNCONFIRMED → NEW
Component: Preferences → Upstream Synchronization
Ever confirmed: true
Priority: -- → P1
Summary: TypeError: Services.search.addEngine is not a function → Port bug 1632448 -Remove now unused confirm and extensionID parameters for nsISearchService.addEngine, and rename it to addOpenSearchEngine
Duplicate of this bug: 1688489

With this the example above can be added. It looks like the url must be a data: uri for the image to work though.

Assignee: nobody → mkmelin+mozilla
Status: NEW → ASSIGNED
Attachment #9199000 - Flags: review?(john)

Comment on attachment 9199000 [details] [diff] [review]
bug1687585_searchengine.patch

Works.

Attachment #9199000 - Flags: review?(john) → review+

Pushed by mkmelin@iki.fi:
https://hg.mozilla.org/comm-central/rev/129709c908c4
Port bug 1632448 -Remove now unused confirm and extensionID parameters for nsISearchService.addEngine, and rename it to addOpenSearchEngine- r=TbSync

Status: ASSIGNED → RESOLVED
Closed: 9 months ago
Resolution: --- → FIXED
Target Milestone: --- → 87 Branch

Comment on attachment 9199000 [details] [diff] [review]
bug1687585_searchengine.patch

[Approval Request Comment]
Catching up with m-c changes. Safe - it's as broken as it can be on beta anyway.

Attachment #9199000 - Flags: approval-comm-beta?

Comment on attachment 9199000 [details] [diff] [review]
bug1687585_searchengine.patch

[Triage Comment]
Small patch, approving for beta.

Attachment #9199000 - Flags: approval-comm-beta? → approval-comm-beta+
You need to log in before you can comment on or make changes to this bug.