Closed Bug 1687586 Opened 4 months ago Closed 1 month ago

[English Grammar Error] - 'Saves to the screenshot directly to the clipboard' - Hovered text when in Firefox devtools

Categories

(DevTools :: General, defect, P5)

Firefox 84
defect

Tracking

(firefox89 fixed)

RESOLVED FIXED
89 Branch
Tracking Status
firefox89 --- fixed

People

(Reporter: dowire2808, Assigned: garima.mazumdar, Mentored)

Details

(Keywords: good-first-bug)

Attachments

(2 files, 1 obsolete file)

User Agent: Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:84.0) Gecko/20100101 Firefox/84.0

Steps to reproduce:

TLDR: This line has incorrect grammar - https://github.com/mozilla/gecko-dev/blob/7ef5cefd0468b8f509efe38e0212de2398f4c8b3/devtools/client/locales/en-US/toolbox-options.ftl#L69

Steps to reproduce on program:

  1. User opens Firefox (currently on Windows 7 Firefox 84.0.2 (64-bit))
  2. User opens Developer Tools in Firefox.
  3. User clicks the three dots on the top right of Developer Tools. User clicks 'Settings'.
  4. User hovers over 'Screenshot to Clipboard' list item under the heading 'Screenshot Behavior'

Actual results:

  1. User sees the hovered text as 'Saves to the screenshot directly to the clipboard' which is incorrect English grammar.

Expected results:

User should have seen 'Saves the screenshot directly to the clipboard'. The first 'to' is incorrect.

Bugbug thinks this bug should belong to this component, but please revert this change in case of error.

Component: Untriaged → Screenshots
Severity: -- → S4
Component: Screenshots → General
Product: Firefox → DevTools
Mentor: aryx.bugmail
Status: UNCONFIRMED → NEW
Ever confirmed: true
Keywords: good-first-bug

Can I give this a try? It would be my first contribution. I'm not sure how to access the codebase. Does someone have to send a link?

https://firefox-source-docs.mozilla.org/contributing/contribution_quickref.html has the instructions how to get the source code, create the patch etc.
https://searchfox.org/ let's you search the code.
Please comment if you have questions or get stuck.

Thanks! I have the source code and a build running on my machine. I was able to find and correct the line with incorrect grammar. Should I use Phabricator to submit the new code? Who should I send it to for review?

Glad to hear it worked for you so far. Please set r=Honza in the commit message to request review or add him as reviewer in Phabricator after you submitted the patch. He is the triage owner for the Bugzilla component DevTools :: General into which the file with the string belongs (top right).

I just commited the patch, I think. I made sure to put r=Honza and the bug number 1687586 in the commit message. If it doesn't show up, or if I did something incorrect, please let me know. I'm not sure I'm using Phabricator correctly, and I want to make sure I follow correct procedure. Thank you.

I don't see your submission. Did moz-phab say the submission succeed and provide a url to the uploaded patch? You likely still need commit access, see https://www.mozilla.org/en-US/about/governance/policies/commit/ how to obtain it. Thank you in advance.

Joseph, I don't see any patch review assigned to me from you.
You might want to take a look at the docs here
https://firefox-source-docs.mozilla.org/mobile/android/geckoview/contributor/contributing-to-mc.html

Honza

Assignee: nobody → joseph.brozinski
Status: NEW → ASSIGNED
Priority: -- → P5

This good-first-bug hasn't had any activity for 2 months, it is automatically unassigned.
For more information, please visit auto_nag documentation.

Assignee: joseph.brozinski → nobody
Status: ASSIGNED → NEW
Assignee: nobody → garima.mazumdar
Status: NEW → ASSIGNED

Hi, I've just fixed this bug and committed the change using moz-phab, could you please let me know if it has been submitted correctly?

(In reply to Garima Mazumdar from comment #11)

Hi, I've just fixed this bug and committed the change using moz-phab, could you please let me know if it has been submitted correctly?

Just commented on the patch, thank you for working on this!

Also, you can use the "Request information from" field at the bottom of this page when asking someone for help. It increases your chances to get an answer since the person will get an notification.

Honza

I've updated the string ID and also updated the reference to it in the code, so while committing, what message should I put?

Flags: needinfo?(odvarko)

(In reply to Garima Mazumdar from comment #13)

I've updated the string ID and also updated the reference to it in the code, so while committing, what message should I put?

You can use something as follows:

Bug 1687586 - [devtools] Fixing tooltip text in DevTools Settings panel

Flags: needinfo?(odvarko)

You should update an existing phab patch not create new one with new changes.

Just use:
hg commit --amend

See also:
https://firefox-source-docs.mozilla.org/contributing/contribution_quickref.html?highlight=amend#to-update-a-submitted-patch

Ohh alright, so should I revert the previous commit? And if I should, how should I go about it?

Flags: needinfo?(odvarko)

Go to Phab, click on "Edit Revision" and remove the Bug ID, so the patch disappears from this bug.
You should also "Edit Deatails" of the attachement and mark it as "Obsolete"

Flags: needinfo?(odvarko)

Comment on attachment 9214866 [details]
WIP: Bug 1687586 - [devtools] Fixing tooltip text in DevTools Settings panel

Revision D111531 was moved to bug 1698595. Setting attachment 9214866 [details] to obsolete.

Attachment #9214866 - Attachment is obsolete: true

I'm not sure if it worked, could you please let me know?

Flags: needinfo?(odvarko)
Attachment #9214760 - Attachment description: "Bug 1687586 - [English Grammar Error] - 'Saves to the screenshot directly to the clipboard' - Hovered text when in Firefox devtools. r=Honza" → Bug 1687586 - [devtools] Fixing tooltip text in DevTools Settings panel

Looks good now.

I assume that the revision that should be updated is this: https://phabricator.services.mozilla.com/D111471

Flags: needinfo?(odvarko)
Attachment #9214760 - Attachment description: Bug 1687586 - [devtools] Fixing tooltip text in DevTools Settings panel → "Bug 1687586 - [English Grammar Error] - 'Saves to the screenshot directly to the clipboard' - Hovered text when in Firefox devtools. r=Honza"

Hi, I've added the changes using moz-phab, please let me know what I should do next

Flags: needinfo?(odvarko)

Hey! Just wanted to follow up, could you please let me know what I have to do next? :)

You need to resolve all the comments made in the attached patch
When uploading changes you should update the existing patch (not create a new one, see also comment #16)
https://phabricator.services.mozilla.com/D111471

Mainly you should:

  • Remove unnecessary changes from the patch
  • Change the String ID

Honza

Flags: needinfo?(odvarko)

Could you tell me how to get rid of the unnecessary changes? Should I get rid of the previous patch and then make the required changes in the necessary files and commit those changes? Or should I add the original lines back to the unnecessary changes and then commit?

Flags: needinfo?(odvarko)

(In reply to Garima Mazumdar from comment #25)

Or should I add the original lines back and then commit?

Yes and use: hg commit --amend

Flags: needinfo?(odvarko)
Attachment #9214760 - Attachment description: "Bug 1687586 - [English Grammar Error] - 'Saves to the screenshot directly to the clipboard' - Hovered text when in Firefox devtools. r=Honza" → Bug 1687586 - [English Grammar Error] - 'Saves to the screenshot directly to the clipboard' - Hovered text when in Firefox devtools. r=Honza
Attachment #9214760 - Attachment description: Bug 1687586 - [English Grammar Error] - 'Saves to the screenshot directly to the clipboard' - Hovered text when in Firefox devtools. r=Honza → Bug 1687586 - [devtools] Fixing title text in the Settings panel. r=Honza
Pushed by jodvarko@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/236bbf59a498
[devtools] Fixing title text in the Settings panel. r=Honza,flod
Status: ASSIGNED → RESOLVED
Closed: 1 month ago
Resolution: --- → FIXED
Target Milestone: --- → 89 Branch
You need to log in before you can comment on or make changes to this bug.