Trunk should have + in version string

RESOLVED WONTFIX

Status

SeaMonkey
Build Config
P3
normal
RESOLVED WONTFIX
16 years ago
14 years ago

People

(Reporter: Boris 'pi' Piwinger, Assigned: Jon Granrose)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
Current trunk builds have version strings like those (user-agent):
Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.2a) Gecko/2002091318
Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.2a) Gecko/2002091408

Before 1.0 we used to have x.y+ in the trunk, where x.y was the version of the
last branch/release. This made trunk builds clearly distinguishable from branch
builds or releases. So now we should be at 1.2a+

pi
Throwing this over to leaf since he has the magic script to rev the version in
the score of contents*.rdf files.  Just changing the version in configure.in &
config/milestone.txt doesn't seem to be enough.
Assignee: seawood → leaf
(Assignee)

Comment 2

16 years ago
now that we don't branch for alpha and beta releases, it's less clear when/if we
should use a "+" on the trunk.

ccing lpham and asasaki since they are working on related trunk versioning bugs.
Priority: -- → P3
Target Milestone: --- → mozilla1.3alpha
(Reporter)

Comment 3

16 years ago
My suggestion for the branch-less time would be to always have the + except for
the very release. So now would be 1.2a+, then only one build 1.2b and then 1.2b+
from the next build on.

pi
(Reporter)

Comment 4

16 years ago
We currently have the situation that trunk builds before and after the 1.2b
release and the release itself have rv:1.2b. Very confusing. As an example,
pople in newsgroups (like news:de.comm.software.mozilla) say they are using 1.2b
which they often don't.

pi
Blocks: 71569
(Assignee)

Updated

16 years ago
Target Milestone: mozilla1.3alpha → Future
(Reporter)

Comment 5

16 years ago
No we have rv:1.2b in trunk before and after 1.2b relase and after branch
1.2final, I assume also in the branch. This is quite ridiculous. It makes the
whole point of the version information bogus.

pi
Summary: Trunk should have + in verson string → Trunk should have + in version string
(Reporter)

Comment 6

16 years ago
It is getting more and more annoying. People in newsgroups (like
de.comm.software.mozilla) constantly keep talking about version 1.3a which isn't
released yet. They don't understand that this is latest-trunk.

pi
(Assignee)

Comment 7

16 years ago
taking
Assignee: leaf → granrose
(Assignee)

Comment 8

15 years ago
engineer gone, wontfix.  if you want it, reopen the bug and reassign it to 
yourself.
Status: NEW → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → WONTFIX
(Reporter)

Comment 9

15 years ago
This is not a bug which simply can get fixed. It would require a change after
each branching or release. This is something only the top maintainers could do.

pi
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.