Closed Bug 1687947 Opened 2 years ago Closed 2 years ago

Atom declarations formatted across multiple lines

Categories

(Developer Infrastructure :: Lint and Formatting, defect)

defect

Tracking

(firefox-esr78 unaffected, firefox84 wontfix, firefox85 wontfix, firefox86 fixed)

RESOLVED FIXED
86 Branch
Tracking Status
firefox-esr78 --- unaffected
firefox84 --- wontfix
firefox85 --- wontfix
firefox86 --- fixed

People

(Reporter: hsivonen, Assigned: sheehan)

References

(Regression)

Details

(Keywords: regression)

Attachments

(1 file)

StaticAtoms.py has this comment:

# Please keep the Atom() definitions on one line as this is parsed by the
#   htmlparser: parser/html/java/htmlparser

Yet, there are now multiline atom declarations.

Please exclude the atom declarations from Python formatting so that each declaration can be on one line.

Regressed by: 1654103
Has Regression Range: --- → yes

These lines are parsed by the htmlparser and are expected to be on a single
line. The black reformat has moved some of these definitions to multiple lines
due to line length. This commit moves all declarations back to a single line and
adds fmt: {off,on} statements so they will be ignored in future reformats.

Assignee: nobody → sheehan
Status: NEW → ASSIGNED
Pushed by cosheehan@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/8abc47cc7404
keep `Atom` declarations on a single line and exclude from `black` formatting r=hsivonen
Status: ASSIGNED → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → 86 Branch

Set release status flags based on info from the regressing bug 1654103

Product: Firefox Build System → Developer Infrastructure
You need to log in before you can comment on or make changes to this bug.