Collapse prefs for home page for tabs/windows into just one pref

VERIFIED WONTFIX

Status

Camino Graveyard
Tabbed Browsing
--
enhancement
VERIFIED WONTFIX
16 years ago
15 years ago

People

(Reporter: S Woodside, Assigned: Simon Fraser)

Tracking

Details

(Reporter)

Description

16 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X; en-US; rv:1.0.1) Gecko/20020914
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X; en-US; rv:1.0.1) Gecko/20020914

When I hit Cmd-T to open a new tab it doesn't load my home page. I realize (now)
there is a pref for this, but I think that it's a bug to ever open a blank
screen without my home page, when I have one specified.

Reproducible: Always

Steps to Reproduce:
Cmd-T (with default prefs, "home page one new tab" is off)
Actual Results:  
blank page

Expected Results:  
load my home page

Comment 1

16 years ago
Simon, are you asking that the default setting for new Chimera profiles be to
load the user's home page in new tabs?
(Reporter)

Comment 2

16 years ago
Yes. In addition, in the spirit of making decisions for the user, I would like
to eliminate the preference for that. Instead, just have a single preference for
"load homepage on new window/tab".

Note that I've only been using tabs for a week now, so there may be some
ultra-important reason to break them out, that I'm not aware of.
(Reporter)

Comment 3

16 years ago
Actually it might be better to have something like this:

[CHECKBOX_LOAD_HOMEPAGE] Load homepage when opening a new window or tab
{
   Home Page: [TEXTFIELD_FOR_HOME_PAGE_URL] [CHECKBOX_SYS_PREFS] Use System
Preferences
   [etc. as current, grays out if !CHECKBOX_LOAD_HOMEPAGE]
}
smfr? any ideas here?
Assignee: pinkerton → sfraser
Status: UNCONFIRMED → NEW
Ever confirmed: true
sounds like bug 164976.

*** This bug has been marked as a duplicate of 164976 ***
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE
v
Status: RESOLVED → VERIFIED
(Reporter)

Comment 7

16 years ago
No, this is definitely not the same bug as bug 164976. I'm changing the name of
the bug from "new tabs don't load my home page" to "[RFE] Collapse prefs for
home page in tabs/windows into just one pref".

I'm going to "reopen bug" hopefully that is OK within your protocol.
Severity: minor → enhancement
Status: VERIFIED → REOPENED
Resolution: DUPLICATE → ---
Summary: new tabs don't load my home page → [RFE] Collapse prefs for home page for tabs/windows into just one pref
(Assignee)

Comment 8

16 years ago
I think most users who make new tabs want them to be blank, because they
immediately type a new url, or drag something into the new tab. Loading the home
page just wastes time in those cases. I'm tempted to 'WONTFIX' this.

Comment 9

16 years ago
Sounds to me like shaping application behavior around an operation the user will
not want to do most of the time. I fully agree with comment #8.
Summary: [RFE] Collapse prefs for home page for tabs/windows into just one pref → Collapse prefs for home page for tabs/windows into just one pref
(Assignee)

Comment 10

15 years ago
Marking WONTFIX per comments.
Status: REOPENED → RESOLVED
Last Resolved: 16 years ago15 years ago
Resolution: --- → WONTFIX
ah, right. vrfy'd wf.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.