Closed Bug 1688229 Opened 9 months ago Closed 9 months ago

Folder Properties dialog always updates the database

Categories

(Thunderbird :: Mail Window Front End, defect)

defect

Tracking

(thunderbird_esr78 fixed, thunderbird86 fixed)

RESOLVED FIXED
87 Branch
Tracking Status
thunderbird_esr78 --- fixed
thunderbird86 --- fixed

People

(Reporter: neil, Assigned: neil)

References

(Regression)

Details

(Keywords: perf, regression)

Attachments

(1 file)

Bug 473458 failed to convert one instance of getDatabase() to msgDatabase...

Attached patch Proposed patchSplinter Review

Since the old property no longer exists, the call always throws, forcing the database to update from the server every time.

Assignee: nobody → neil
Attachment #9198682 - Flags: review?(geoff)

Funny, a 12 year old bug and regression that nobody noticed :) . Thanks for finding and fixing it.

Status: NEW → ASSIGNED
Keywords: regression

Comment on attachment 9198682 [details] [diff] [review]
Proposed patch

Oh dear. :-)

Attachment #9198682 - Flags: review?(geoff) → review+
Target Milestone: --- → 87 Branch

Pushed by mkmelin@iki.fi:
https://hg.mozilla.org/comm-central/rev/1517626fcea2
Fix last reference to getDatabase after bug 473458. r=darktrojan

Status: ASSIGNED → RESOLVED
Closed: 9 months ago
Resolution: --- → FIXED

Comment on attachment 9198682 [details] [diff] [review]
Proposed patch

[Approval Request Comment]
Regression caused by (bug #): 473458
User impact if declined: Extra server traffic when opening folder properties dialog
Risk to taking this patch (and alternatives if risky): Low, fixing unwanted exception

Attachment #9198682 - Flags: approval-comm-beta?

Comment on attachment 9198682 [details] [diff] [review]
Proposed patch

[Triage Comment]
Approved for beta

Thanks for the fix. Hopefully 13 is not unlucky.

Attachment #9198682 - Flags: approval-comm-beta? → approval-comm-beta+
Keywords: perf

Comment on attachment 9198682 [details] [diff] [review]
Proposed patch

[Approval Request Comment]
Regression caused by (bug #): bug 473458
User impact if declined: slight perf degradation
Testing completed (on c-c, etc.): beta
Risk to taking this patch (and alternatives if risky): very safe

Attachment #9198682 - Flags: approval-comm-esr78?

Comment on attachment 9198682 [details] [diff] [review]
Proposed patch

[Triage Comment]
Approved for esr78

Attachment #9198682 - Flags: approval-comm-esr78? → approval-comm-esr78+
You need to log in before you can comment on or make changes to this bug.