share functions between ico and bmp decoder, making them non-member functions

RESOLVED FIXED

Status

()

Core
ImageLib
RESOLVED FIXED
16 years ago
16 years ago

People

(Reporter: Biesinger, Assigned: Biesinger)

Tracking

Trunk
x86
Windows 98
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

several functions in the BMP and ICO Decoder are identical in them.
(specifically, the Set*Pixel ones). they should be shared.

Comment 2

16 years ago
Comment on attachment 99296 [details] [diff] [review]
patch

r=pavlov
Attachment #99296 - Flags: review+

Comment 3

16 years ago
Comment on attachment 99296 [details] [diff] [review]
patch

sr=tor
Attachment #99296 - Flags: superreview+
checked in.
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → FIXED

Comment 5

16 years ago
Bug 169477 might be a regression of this?
Before this patch ICO was using USE_RGBA1-define but now
it is using the same as BMP (USE_RGB-define).
Or maybe the problem is somewhere else, I don't have time to test it.
You need to log in before you can comment on or make changes to this bug.