entering "www.foo.com:7500" into URL bar results in "www.foo.com is not a registered protocol"

RESOLVED DUPLICATE of bug 155344

Status

SeaMonkey
Location Bar
--
minor
RESOLVED DUPLICATE of bug 155344
16 years ago
10 years ago

People

(Reporter: vlad, Assigned: Joe Hewitt (gone))

Tracking

Trunk
x86
Windows XP

Firefox Tracking Flags

(Not tracked)

Details

(URL)

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.1) Gecko/20020826
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.1) Gecko/20020826

(Note: may be intentional, but I couldn't find any reference to it in bugzilla
or release notes.  The behaviour changed at some point between this snapshot and
1.0.)

Typing in "www.foo.com:7500" or any other hostname:port combination, without a
preceding http:// or other protocol results in "www.foo.com is not a registered
protocol".  Previous versious would assume http:// and attempt that (I'm
assuming if the first part wasn't a valid protocol and looked like a hostname or
something).  Entering just "www.foo.com" performs the expected behaviour.


Reproducible: Always

Steps to Reproduce:
1. Ctrl-L
2. www.foo.com:7500
3. Enter


Actual Results:  
(See Details)

Expected Results:  
(See Details)

Comment 1

16 years ago

*** This bug has been marked as a duplicate of 155344 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE
Product: Core → SeaMonkey
You need to log in before you can comment on or make changes to this bug.