[PP]Input field contains character symbol by default

VERIFIED FIXED in M11

Status

()

Core
Layout: Form Controls
P3
major
VERIFIED FIXED
18 years ago
18 years ago

People

(Reporter: Chris Petersen, Assigned: buster)

Tracking

Trunk
PowerPC
Mac System 8.6
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

18 years ago
Build: Apprunner
Version: 1999102008
Platforms: Mac
Other Platform: Works on Windows 95, Linux (Red Hat 6.0).
Expected Results: The input field show be empty by default
What I got: A "cross" symbol is displayed in the input field.

Steps to reproduce:

1) Launch Apprunner
2) Open test cases: http://slip/projects/marvin/html/input_size.html
3) The input field contains the symbol.

Updated

18 years ago
Assignee: karnaze → kmcclusk

Comment 1

18 years ago
Reassigning to Kevin.

Updated

18 years ago
Assignee: kmcclusk → buster
reassigning to buster
(Assignee)

Updated

18 years ago
Assignee: buster → brade
(Assignee)

Comment 3

18 years ago
assigned to brade, since it's a mac-only bug.  kathy, can you see what's going
on here?  all the code involved on the content and layout side is XP, the only
platform code involved here is rendering (I think.)  cc'ing the other editor
macheads in case anybody knows anything about this.
Chris, do you see this in all text controls, or just this one simple test case?

Comment 4

18 years ago
This looks fine to me in a build from yesterday.

Comment 5

18 years ago
Oh, I do see this now, even in the editor init page. It looks like we're getting
one char extra from somewhere.

Comment 6

18 years ago
Oh, these symbols are showing up elsewhere too. See the mail start page for an
example. I think someone in layout left in some debug code.

Comment 7

18 years ago
Aha! these are non-breaking spaces showing up. See the editor init page for
examples.

Updated

18 years ago
Assignee: brade → kipp

Comment 8

18 years ago
Kipp owned up to causing this. Reassigning.

Comment 9

18 years ago
This sounds like an encoding problem to me.

Comment 10

18 years ago
(charset MacRoman vs. Latin1)

Updated

18 years ago
Status: NEW → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → FIXED

Comment 11

18 years ago
*** Bug 16889 has been marked as a duplicate of this bug. ***

Comment 12

18 years ago
*** Bug 16878 has been marked as a duplicate of this bug. ***

Comment 13

18 years ago
*** Bug 16986 has been marked as a duplicate of this bug. ***

Updated

18 years ago
Status: RESOLVED → REOPENED

Comment 14

18 years ago
I still see this bug on Mac.
It no longer appears in the editor window but it does appear in each empty input
textfield.
Reopening bug.

Updated

18 years ago
Blocks: 16961

Updated

18 years ago
Assignee: kipp → brade
Status: REOPENED → NEW

Comment 15

18 years ago
Can you please debug it out then on the mac? I don't see it on linux...thanks

Updated

18 years ago
Resolution: FIXED → ---

Updated

18 years ago
Assignee: brade → kipp

Comment 16

18 years ago
reassign back to Kipp.  I think he now has enough info to debug this himself.

Updated

18 years ago
Status: NEW → ASSIGNED
Target Milestone: M11

Updated

18 years ago
Status: ASSIGNED → RESOLVED
Last Resolved: 18 years ago18 years ago
Resolution: --- → FIXED

Comment 17

18 years ago
With kathy's help, it's fixed.
(Reporter)

Updated

18 years ago
Status: RESOLVED → VERIFIED
(Reporter)

Comment 18

18 years ago
Fixed in the Nov 1 build (1999110108).
You need to log in before you can comment on or make changes to this bug.