If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Tabbed browsing: URL typed into location bar, but hit enter key and no go. Also, switch tab, location bar has other tab's URL in it still.

RESOLVED WORKSFORME

Status

SeaMonkey
Tabbed Browser
RESOLVED WORKSFORME
15 years ago
9 years ago

People

(Reporter: Dennis Spaag, Assigned: jag (Peter Annema))

Tracking

Trunk
x86
Windows 2000

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
User-Agent:       Opera/6.05 (Windows 2000; U)  [en]
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.2a) Gecko/20020910

I tried opening a new tab and copying a URL into it.  I hit enter and it didn't go anywhere.  Also, tried typing a URL into the location bar, hit enter - no go.  When I switched to another (already open) tab, it displayed the URL that did not load.  Refreshing the page did not cause the location bar to show the displayed page's URL, nor did following a link.   

This only showed up today.  When I first started the browser, it spent an inordinate amount of time displaying the splash screen.  I then opened a link from my email client.  Mozilla opened a new window for this and displayed it properly, but the initial Mozilla "instance" came up with an empty screen and did not load my bookmarks or home page (it did load the correct skin though).

Reproducible: Sometimes

Steps to Reproduce:
1. Mozilla 1.2a
2. Type or paste link into a new tab (with more than one open).
3. Try to navigate to that page.

Actual Results:  
The browser remained on the new open tab and did not appear to try to fetch the requested page. 

Expected Results:  
Retrieved the requested URL.

Comment 1

15 years ago
On Win32 (win98 and win2k), this happens when you start Mozilla twice in
quick succession (such as when you accidentally double-click the icon in
Windows's quick launch bar, or when you start Mozilla before the -turbo
system tray icon has completely loaded).  A symptom of this problem is
that clicking links does not change the URL bar.

Because new windows created with (Accel+N) never suffer from this problem,
there's an easy workaround: Make a new window, and then Close the window
with the problem.

It feels like a race condition.  I've seen it since before Mozilla 1.0.
Duplicate?

Comment 2

15 years ago
->Tabbed Browser
Assignee: asa → jaggernaut
Component: Browser-General → Tabbed Browser
QA Contact: asa → pmac

Comment 3

15 years ago
reporter: can you reproduce this bug with a recent build of mozilla (for
example, 1.3a)? if so, please comment again with details. if not, please resolve
this bug as WORKSFORME. thanks.
(Reporter)

Comment 4

15 years ago
I have not ran across this bug in a while.  I believe that Damian is correct
about it being a race condition.  In which case, the fix for this bug is
irrelevent if the race condition is prevented from happening.  I have not been
able to get the race condition after a few attempts with the 20030101 build of
1.3b.  I'll mark it as works for me...
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → WORKSFORME
Product: Core → SeaMonkey
You need to log in before you can comment on or make changes to this bug.