Closed Bug 1689623 Opened 9 months ago Closed 9 months ago

Crash in [@ nsWindow::IsPopup]

Categories

(Core :: Graphics: WebRender, defect)

Unspecified
Linux
defect

Tracking

()

RESOLVED FIXED
87 Branch
Tracking Status
firefox-esr78 --- unaffected
firefox85 --- unaffected
firefox86 --- wontfix
firefox87 --- fixed

People

(Reporter: sefeng, Assigned: stransky)

References

(Blocks 2 open bugs, Regression)

Details

(Keywords: crash, regression, regressionwindow-wanted)

Crash Data

Attachments

(1 file)

Crash report: https://crash-stats.mozilla.org/report/index/cbf7dc4c-d67f-43b3-9ab6-823690210129

Reason: SIGSEGV /SEGV_MAPERR

Top 10 frames of crashing thread:

0 libxul.so nsWindow::IsPopup widget/gtk/nsWindow.cpp:1279
1 libxul.so mozilla::widget::GtkCompositorWidget::GetTransparentRegion widget/gtk/GtkCompositorWidget.cpp:131
2 libxul.so mozilla::wr::RenderCompositorSWGL::AllocateMappedBuffer gfx/webrender_bindings/RenderCompositorSWGL.cpp:126
3 libxul.so mozilla::wr::RenderCompositorSWGL::StartCompositing gfx/webrender_bindings/RenderCompositorSWGL.cpp:162
4 libxul.so <webrender_bindings::swgl_bindings::SwCompositor as webrender::composite::Compositor>::start_compositing gfx/webrender_bindings/src/swgl_bindings.rs:1658
5 libxul.so webrender::renderer::Renderer::draw_frame gfx/wr/webrender/src/renderer/mod.rs:4549
6 libxul.so webrender::renderer::Renderer::render_impl gfx/wr/webrender/src/renderer/mod.rs:2127
7 libxul.so webrender::renderer::Renderer::render gfx/wr/webrender/src/renderer/mod.rs:1873
8 libxul.so wr_renderer_render gfx/webrender_bindings/src/bindings.rs:639
9 libxul.so mozilla::wr::RendererOGL::UpdateAndRender gfx/webrender_bindings/RendererOGL.cpp:186

A few Linux users hit this crash. Looks legit to me because the code is new.

Flags: needinfo?(stransky)

Blocking sw-wr for now. Marking S2 for high volume on Nightly.
It would be great to find a regression range here.

Blocks: sw-wr, wr-linux
Severity: -- → S2

Looks like mWidget is null.

Assignee: nobody → stransky
Flags: needinfo?(stransky)
Pushed by stransky@redhat.com:
https://hg.mozilla.org/integration/autoland/rev/88654fa3af79
[Linux] Check mWidget before use at GtkCompositorWidget::GetTransparentRegion(), r=lsalzman
Status: NEW → RESOLVED
Closed: 9 months ago
Resolution: --- → FIXED
Target Milestone: --- → 87 Branch

The patch landed in nightly and beta is affected.
:stransky, is this bug important enough to require an uplift?
If not please set status_beta to wontfix.

For more information, please visit auto_nag documentation.

Flags: needinfo?(stransky)

Backport would need also Bug 1689245 and we don't use SW-WR in FF86 so I think we don't need to backport.

Flags: needinfo?(stransky)
You need to log in before you can comment on or make changes to this bug.