Status

VERIFIED WONTFIX
17 years ago
14 years ago

People

(Reporter: dtomaszuk, Assigned: asa)

Tracking

Trunk
x86
Other

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

17 years ago
Some scripts (javascript) must be in section <head> and it looks like:
<script src="file.js" type="text/javascript"></script>
I think it will better when it will look like:
<link href="file.js" type="text/javascript" rel="script">
just like stylesheet. I think it is compatible with W3C.

Comment 1

17 years ago
This is not going to happen.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → WONTFIX

Comment 2

17 years ago
vrfy
Status: RESOLVED → VERIFIED
(Reporter)

Comment 3

17 years ago
>This is not going to happen.
Why?

Comment 4

17 years ago
Because '<script>' is the element defined to load script, and '<link>' is not,
according to published standards. This would be "compatible with W3C" only by 
a perverted reading of those standards.
*** Bug 186965 has been marked as a duplicate of this bug. ***

Comment 6

16 years ago
Why was I CCed and what does Bug 186965 have to do w/ this one?

Comment 7

16 years ago
bug 186965 was marked as a dup of this bug (although the intended dup target 
was really bug 186964). pinkerton suffers from dyslexia or something. If you 
are the reporter of a duplicate bug, you will automagically be added to the 
CC list of the duped-to bug. But, if a duplicate bug is reopened, you aren't 
automagically removed from the CC.
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.