Closed Bug 1689995 Opened 6 months ago Closed 6 months ago

Update the in-tree version of Cairo to release 1.17.4

Categories

(Core :: Graphics, enhancement)

enhancement

Tracking

()

RESOLVED DUPLICATE of bug 739096

People

(Reporter: jfkthame, Assigned: jfkthame)

References

Details

This is a prerequisite to implement hyperlinks in PDF output (bug 454059), because the current version of cairo we have in the tree doesn't include the necessary APIs (cairo_tag_begin, cairo_tag_end) to create hyperlinks.

The latest Cairo snapshot (currently 1.17.4) provides this, although we will need to merge some of our local modifications in order to integrate it with gecko; it's not usable just as a drop-in replacement.

Depends on: 1689998
Summary: Update the in-tree version of Cairo to release 1.7.4 → Update the in-tree version of Cairo to release 1.17.4
Status: NEW → RESOLVED
Closed: 6 months ago
Resolution: --- → DUPLICATE
Duplicate of bug: 739096
You need to log in before you can comment on or make changes to this bug.