Style information in Clipboard uses inappropriate font

RESOLVED FIXED in mozilla1.2beta

Status

()

RESOLVED FIXED
16 years ago
16 years ago

People

(Reporter: isw, Assigned: nhottanscp)

Tracking

Trunk
mozilla1.2beta
PowerPC
Mac System 9.x
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

16 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC; en-US; rv:1.2a) Gecko/20020910
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC; en-US; rv:1.2a) Gecko/20020910

I've been copying text from this site's pages and e-mailing it to friends (with
Eudora) for a long time.Suddenly, with Build 2002091014, the font of the dragged
text has changed. I used to come across in the font Eudora uses when I type
mail; now it frequently (but not always) shows up in the System Font (Charcoal)
at a very large point size.

When it happens, it happens with drag-drop and copy-paste.

Reproducible: Sometimes

Steps to Reproduce:
1. Find a web page such as the one I use (see above)
2. Highlight some text
3. Drag it (or copy-paste) to another app (Eudora)
4. Not always, but sometimes, the text will show up in the system font (Charcoal)

Actual Results:  
Text was sometimes in the wrong font (Charcoal)

Expected Results:  
What it used to do; paste in the font selected by the *target* app. I have set
Mozilla to use Geneva for web page text, and Eudora to use Mishiwaka for text.
Until now, the text has always been pasted in Mishiwaka.

I'm using the "LitleMozilla" theme, but that hasn't changed for several Moz updates.

Comment 1

16 years ago
Isaac, can you provide an example URL that doesn't require logging in?
(Reporter)

Comment 2

16 years ago
I forgot about the password -- they only started requiring it recently. It's the
most common (for me) site to copy pages.

I have a suspicion this is not URL-related, but I'll try some copies on other
pages I visit.
(Reporter)

Comment 3

16 years ago
I have confirmed that this bug is not URL specific.

Comment 4

16 years ago
Confirmed using Mac/1.2a/9.2.2. Copy the text from comment 3 and use the Finder's Edit/Show 
Clipboard command. You'll see the font face information was not stored on the Clipboard.

Reassigning to XPToolkit/Widgets. Revising summary.
Assignee: asa → jaggernaut
Status: UNCONFIRMED → NEW
Component: Browser-General → XP Toolkit/Widgets
Ever confirmed: true
QA Contact: asa → jrgm
Summary: copy-paste or drag sometimes delivers text in wrong font → Mozilla doesn't copy text style information to Clipboard
(Assignee)

Comment 5

16 years ago
reassign to nhotta

Mozilla did not creat 'styl' before bug 168041, it copied 'TEXT' with no style.
Currently, the style is created based on the script of the text. For font face,
the application font (on OS X) or the system font (on OS 9) is used.
Assignee: jaggernaut → nhotta
(Reporter)

Comment 6

16 years ago
Using the system font will essentially *never* be what a user wants. I liked it
a lot better before.

If you *really* feel the necessity, how about a selection in the preferences?
(Assignee)

Comment 7

16 years ago
It is based on the API used for script -> face mapping does not accept
application font for MacOS 9.
I think that can be changed to call different API (and use the application font)
for the default script under OS 9.
Status: NEW → ASSIGNED

Comment 8

16 years ago
Can't we get the font face from the content?

Also, I think the summary of this bug is misleading. The reporter does *not*
want 'styl', but we give it to them. The bug could be construed as a request to
build up 'styl' info that represents the entire selection (with fonts, colors,
bold etc).
(Assignee)

Comment 9

16 years ago
>Can't we get the font face from the content?
I don't know, but that should be better than using the default face.
(Reporter)

Comment 10

16 years ago
I'm not a developer, just a user, so this may be a naive question:

What's wrong with the way Moz always worked before? Except for the occasional
selection of a javascript snippet [Bug 112021], it was fine, pasting the text in
the target app's selected font.

Now, when it delivers text in the system font (which it does not do
consistently), I have to open the formatting tools in Eudora and rework
everything. A big pain.

As for the 'styl' info: I've been a Mac user for many years; it's almost *never*
that I want to copy all the formatting from a source document. Usually, I just
want the text.
isn't this a dupe of bug 79864? we have no plans to place the webpage styles on
the clipboard.

Comment 12

16 years ago
> What's wrong with the way Moz always worked before

'styl' data was added, because that's the only way Mac OS 9 (non-unicode) apps
can tell what script (i.e. language) the data is in, via the font. Without this,
dragging Japanese text to a clipping, or copying and pasting it, would result in
garbage.

Fixing summary.
Summary: Mozilla doesn't copy text style information to Clipboard → Style information in Clipboard uses inappropriate font
(Assignee)

Updated

16 years ago
Target Milestone: --- → mozilla1.2beta
(Assignee)

Comment 13

16 years ago
Created attachment 100342 [details] [diff] [review]
For Classic, use script mgr to get application font instead of the appearance API which only supports system fonts for Classic.
(Assignee)

Comment 14

16 years ago
Comment on attachment 100342 [details] [diff] [review]
For Classic, use script mgr to get application font instead of the appearance API which only supports system fonts for Classic.

r=ftang
Attachment #100342 - Flags: review+

Comment 15

16 years ago
Comment on attachment 100342 [details] [diff] [review]
For Classic, use script mgr to get application font instead of the appearance API which only supports system fonts for Classic.

sr=sfraser
Attachment #100342 - Flags: superreview+
(Assignee)

Comment 16

16 years ago
This was checked in to the trunk (available in today's trunk).
The clipboard data still has the style but it uses the application font instead
of the system. The size is still larger than the one used for non styled text
but this cannot be changed since the size used by the clipboard is not
accessible, so we use the default size for the application font.
Status: ASSIGNED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → FIXED
(Reporter)

Comment 17

16 years ago
Well, for a long time, dragging text worked just fine except rarely I'd get some
javascript instead (bug 112021).

In later releases, dragging worked fine except it would sometimes deliver the
text in the system font, requiring an edit.

Now it *always* delivers the text in the wrong font size, so it always requires
an edit.

I'm not sure that's an improvement...
(Reporter)

Comment 18

16 years ago
With regard to comment #16, which mentions using the "application font":

(This is on Build # 2002101703).

I've used the font "Mishawaka" in Eudora for a long time. With the most recent
changes, text dragged from Moz has been coming across in "Geneva"; it used to
show up in Mishawaka.

I just edited Moz's prefs to use Mishawaka 10 pt. for its san-serif font.
Nowhere in the prefs is Geneva selected. Rebooted Moz. New font works.

Text dragged from Moz to Eudora is still coming across in Geneva, so I'm curious
as to exactly which application the clipboard is using to choose the font?
Command C-Command V (which surely uses the clipboard) also delivers the text in
Geneva.

I should mention that during the test, I got an instance of bug # 112021, so
whatever changes have been made haven't resolved that one.
(Reporter)

Comment 19

16 years ago
I've been using late versions of Mozilla with this "fix" for several weeks now.

It is a royal pain to have to edit *every* instance of text I copy from Mozilla
to any other app.

No other app I know of *always* copies text in the wrong font. Is it possible to
provide a hack or a preference to get Mozilla to work the same as every other
application I've ever used? 
(Assignee)

Comment 20

16 years ago
Under OS 9, the API ::GetThemeFont does not accept kThemeApplicationFont so the
user's change made in "Apperance Control Panel" cannot be used by application.
(Reporter)

Comment 21

16 years ago
Now that Mac classic mode has been separated from the OS X line, I sure hope
somebody will fix this very annoying bug. Every time I copy text from Moz to any
other app, it winds up in the wrong font and size. That is NOT the way Mac apps
are supposed to work.
You need to log in before you can comment on or make changes to this bug.