Status

SeaMonkey
General
RESOLVED INVALID
15 years ago
13 years ago

People

(Reporter: Eugen, Assigned: asa)

Tracking

Trunk
x86
Windows XP

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.1) Gecko/20020826
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.1) Gecko/20020826

All menu entries except "Home" are blinkin, in IE they don't.

Reproducible: Always

Steps to Reproduce:
1. goto this page

Actual Results:  
Menu entries are blinking.

Expected Results:  
Menu entries should not blink.

Comment 1

15 years ago
In "obenstyle.css" there is a line:

a:link {  font-family: Verdana, Arial, Helvetica, sans-serif; font-size: 12px;
color: #000000; text-decoration: blink; font-style: normal}

(before it are a, a:active, a:hover). Probably Mozilla interprets this
styleshhet differently (correctly, I suppose) than IE. By the way, the links
also blink in NN4X if CSS is enabled. Any CSS experts around ?

Comment 2

15 years ago
Clickable link: <http://www.pixelmania.at/index.htm>
Style sheet: <http://www.pixelmania.at/obenstyle.css>

Note that a:link, which is the pseudo-class for an *unvisited* link, includes
the CSS "text-decoration: blink;" which causes every link except home (which is
loaded when you access the page so it already is a visited link) to blink.

As a CSS1-conforming user agent, we are behaving properly by making those links
blink. (The effect can be disabled with the browser.blink_allowed pref.) IE does
not render the blinking effect because blinking text is annoying and Microsoft
is not required to support it to be CSS1 compliant. (I couldn't tell you why
Mozilla *does* support blinking text, though. That's a mystery.) Technically,
the author requested that unvisited links be rendered in blinking text and we
are obeying.

I don't think this is worth Tech Evangelism's time, so I'm resolving INVALID.
You may want to personally notify the site's author of this problem.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → INVALID
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.