Closed Bug 1690561 Opened 3 months ago Closed 3 months ago

Adjust content context menu item labels for clarity/brevity

Categories

(Firefox :: Menus, enhancement, P1)

Desktop
All
enhancement

Tracking

()

VERIFIED FIXED
88 Branch
Tracking Status
firefox88 --- verified

People

(Reporter: Gijs, Assigned: ewright)

References

(Blocks 2 open bugs)

Details

(Whiteboard: [proton-context-menus])

Attachments

(1 file)

As part of this bug we want to make the following labeling changes:

  • Open Link in New Container Tab --> Open Link in New Container

  • Copy Link Location --> Copy Link

  • Bookmark This Link --> Bookmark Link

  • Copy Image Location --> Copy Image Link

  • Set As Desktop Background --> Set Image as Desktop Background

  • Inspect Element --> Inspect

  • "(No spelling suggestions)"; drop parentheses

Type: defect → enhancement

What about:
"Copy Video Location" and "Copy Audio Location"? I assume the same treatment as "Copy Image Location" by changing "Location" to "Link".

Also, for string changes we are not putting this behind any prefs, correct?

Assignee: nobody → ewright
Status: NEW → ASSIGNED

(In reply to Erica Wright [:ewright] from comment #1)

What about:
"Copy Video Location" and "Copy Audio Location"? I assume the same treatment as "Copy Image Location" by changing "Location" to "Link".

Yes, sorry, the video/audio changes came through after I filed this bug and I forgot to update it.

Also, for string changes we are not putting this behind any prefs, correct?

Correct!

Pushed by ewright@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/d8804e8807b3
Update context menu strings for clarity. r=Gijs,fluent-reviewers

As per guidance from Vicky, for tracking, we're marking all the bugs that people are working on as P1.

Priority: -- → P1
Status: ASSIGNED → RESOLVED
Closed: 3 months ago
Resolution: --- → FIXED
Target Milestone: --- → 88 Branch

(In reply to :Gijs (he/him) from comment #0)

  • Copy Link Location --> Copy Link

This makes the command slightly more ambiguous and the user expectation can be shifted to getting a paste of the link text with the link functionality when pasting in rich text environments.

Duplicate of this bug: 1692628

with the "Copy Link Location" label changing to "Copy Link" the keyboard shortcut has changed from "A" to "L". Assuming the user is a right-handed mouse user and has their left hand resting naturally on the home row keys, it is inconvenient to move to hit "L" after right clicking links to copy the link.

Would it be possible to revert this label change or at the very least provide a shortcut that is on the left side of the keyboard again? Maybe back to "C" or something? or is this shortcut configurable somehow?

related https://bugzilla.mozilla.org/show_bug.cgi?id=423905

Blocks: 1697682

if "Copy Link Location" is no longer an option, would "Copy Link Address" work in its place? that way the "A" keyboard shortcut could be preserved rather than changing it to "L"

Verified that the labeling changes from comment 0 and comment 1 are correctly made and they work as expected in latest Nightly 88.0a1 across platforms (Windows 10, macOS 11.3 and Ubuntu 18.04). I'll close this bug as verified fixed even though it has status affected for firefox87 flag, that was Nightly 87.

Status: RESOLVED → VERIFIED

Thanks!

Regressions: 1700418
Duplicate of this bug: 1698649
Regressions: 423905
No longer regressions: 423905
Regressions: 423905
No longer regressions: 423905
Regressions: 1701324
Blocks: 1710399
You need to log in before you can comment on or make changes to this bug.