Closed Bug 1690854 Opened 10 months ago Closed 10 months ago

Remove slow startup warning

Categories

(Core :: Performance, enhancement)

enhancement

Tracking

()

RESOLVED FIXED
88 Branch
Tracking Status
firefox88 --- fixed

People

(Reporter: esmyth, Assigned: emmamalysz)

References

(Blocks 5 open bugs)

Details

(Whiteboard: [proton-infobars])

Attachments

(1 file)

Current behavior

When a profile is more than 90 days old and the average of the last five[1] startups is more than 20[1] seconds, a user will see a notice with buttons to either permanently ignore the warning or "Learn Hot to Speed It Up." The latter directs the user to the SUMO page to refresh their profile.

[1] Configurable via pref

Issue

A profile refresh is a high friction recommendation to address slow startups that is potentially harmful to the user's experience. Furthermore, we don't have confidence that it will address the cause of the slow startup. For example, for users on older systems a "slow" startup may be normal. Alternately, if the user has third party software performing DLL-injection which slows down startup, a profile refresh will not help. Additional discussion in this deck.

New behavior

No notice is shown to users when their startup is "slow." Other initiatives will address the real and perceived performance of slower startups.

Whiteboard: [proton-infobars]
Assignee: nobody → emalysz
Status: NEW → ASSIGNED
Pushed by emalysz@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/42fef53a4855
remove slow startup notification r=mconley
Status: ASSIGNED → RESOLVED
Closed: 10 months ago
Resolution: --- → FIXED
Target Milestone: --- → 88 Branch
Duplicate of this bug: 1672580
You need to log in before you can comment on or make changes to this bug.