Closed Bug 1691722 Opened 3 years ago Closed 3 years ago

2.28 - 8.95% rasterflood_svg / tp5o_scroll (linux64-shippable, linux64-shippable-qr, windows10-64-shippable) regression on push f72030ee528939167d88804b61faa200246e037c (Sun February 7 2021)

Categories

(Core :: Web Painting, defect)

Firefox 87
defect

Tracking

()

RESOLVED FIXED
88 Branch
Tracking Status
firefox-esr78 --- unaffected
firefox85 --- unaffected
firefox86 --- unaffected
firefox87 --- wontfix
firefox88 --- fixed

People

(Reporter: alexandrui, Unassigned)

References

(Regression)

Details

(4 keywords)

Perfherder has detected a talos performance regression from push f72030ee528939167d88804b61faa200246e037c. As author of one of the patches included in that push, we need your help to address this regression.

Regressions:

Ratio Suite Test Platform Options Absolute values (old vs new)
9% tp5o_scroll linux64-shippable e10s stylo 1.22 -> 1.33
9% tp5o_scroll linux64-shippable e10s stylo 1.22 -> 1.33
8% tp5o_scroll windows10-64-shippable e10s stylo 1.31 -> 1.42
7% tp5o_scroll linux64-shippable-qr e10s stylo webrender 2.25 -> 2.41
2% rasterflood_svg linux64-shippable e10s stylo 9,641.07 -> 9,860.71

Details of the alert can be found in the alert summary, including links to graphs and comparisons for each of the affected tests. Please follow our guide to handling regression bugs and let us know your plans within 3 business days, or the offending patch(es) will be backed out in accordance with our regression policy.

For more information on performance sheriffing please see our FAQ.

Flags: needinfo?(mikokm)

These regressions are expected.

In order to have a correct hit testing result, we need a mechanism to collect hit test flags and areas for every frame on the screen during display list building. The previous version of the code avoided some of this by applying an optimization that worked in most cases, but also caused bugs such as bug 1676466.
The regression is caused by additional display items being created to pass along the hit testing information. Bug 1526970 is expected to undo most of these performance regressions.

Flags: needinfo?(mikokm)

Set release status flags based on info from the regressing bug 1534549

== Change summary for alert #28735 (as of Thu, 11 Feb 2021 07:40:45 GMT) ==

Regressions:

Ratio Suite Test Platform Options Absolute values (old vs new)
18% fandom ContentfulSpeedIndex linux64-shippable-qr nocondprof warm webrender 199.79 -> 235.92
15% fandom ContentfulSpeedIndex linux64-shippable-qr nocondprof warm webrender 203.50 -> 233.08
13% fandom ContentfulSpeedIndex linux64-shippable nocondprof warm 211.08 -> 238.67
13% amazon-search LastVisualChange android-hw-g5-7-0-arm7-api-16-shippable cold nocondprof 6,796.42 -> 7,666.92
12% fandom ContentfulSpeedIndex macosx1014-64-shippable-qr nocondprof warm webrender 374.42 -> 419.67
10% amazon-search LastVisualChange android-hw-g5-7-0-arm7-api-16-shippable nocondprof warm 4,448.71 -> 4,901.00
6% amazon-search ContentfulSpeedIndex android-hw-g5-7-0-arm7-api-16-shippable cold nocondprof 2,179.00 -> 2,309.17
5% amazon-search PerceptualSpeedIndex android-hw-g5-7-0-arm7-api-16-shippable cold nocondprof 2,220.92 -> 2,332.58
3% ebay-kleinanzeigen-search LastVisualChange android-hw-g5-7-0-arm7-api-16-shippable nocondprof warm webrender 2,694.92 -> 2,782.92

For up to date results, see: https://treeherder.mozilla.org/perfherder/alerts?id=28735

Note the additional page load regressions detected in comment 3. Are these also expected?

Flags: needinfo?(mikokm)

(In reply to Dave Hunt [:davehunt] [he/him] ⌚GMT from comment #4)

Note the additional page load regressions detected in comment 3. Are these also expected?

Yes, this was expected to regress especially first paint performance across the board.

Flags: needinfo?(mikokm)

Thanks Miko. It looks like bug 1526970 addressed the Talos regressions as mentioned in comment 1.

Ionut: Could you check to see if we also had improvements in Raptor?

Flags: needinfo?(igoldan)

(In reply to Dave Hunt [:davehunt] [he/him] ⌚GMT from comment #6)

Thanks Miko. It looks like bug 1526970 addressed the Talos regressions as mentioned in comment 1.

Ionut: Could you check to see if we also had improvements in Raptor?

I visually noticed an improvement across all tests around the time bug 1526970 landed.
Perfherder didn't generate anything though, because of the slight noise. Also, this regression' s magnitude (when it landed) was artificially increased by bug 1692426, which happened at 2-3 days difference.

I'd say we can close this as fixed.

Flags: needinfo?(igoldan)
Status: NEW → RESOLVED
Closed: 3 years ago
Resolution: --- → FIXED
Target Milestone: --- → 88 Branch
Has Regression Range: --- → yes
You need to log in before you can comment on or make changes to this bug.