[FEATURE] Watch Thread

VERIFIED FIXED in Future

Status

P3
normal
VERIFIED FIXED
19 years ago
11 years ago

People

(Reporter: laurel, Assigned: Bienvenu)

Tracking

({helpwanted})

Trunk
Future
helpwanted
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [nsbeta3-])

(Reporter)

Description

19 years ago
This bug is to track implementation of Watch Thread.
(Reporter)

Updated

19 years ago
QA Contact: lchiang → fenella

Updated

19 years ago
Assignee: phil → putterman
Target Milestone: M15

Comment 1

19 years ago
Reassign to putterman, cc bienvenu. Not a B1 feature, so TFV M15

Updated

19 years ago
Blocks: 10791

Updated

19 years ago
Status: NEW → ASSIGNED
Target Milestone: M15 → M18

Comment 2

19 years ago
Shouldn't this be in beta3?
Keywords: nsbeta3

Comment 3

19 years ago
moving to future milestone.  This feature won't be in.
Target Milestone: M18 → Future
(Reporter)

Comment 4

19 years ago
logged bug to remove Watch Thread from the message filter ui: bug #44174.

Updated

19 years ago
Blocks: 44156

Updated

19 years ago
Whiteboard: [nsbeta3-]

Comment 5

18 years ago
please move this bug to a much sooner target milestone (suggest 0.6 or 0.8 latest).

Comment 6

18 years ago
*** Bug 61718 has been marked as a duplicate of this bug. ***

Comment 7

18 years ago
Please include these two features soon:

- message filters that mark thread or message as watched
- view - messages - watched threads (don't include unread, or make option)

Comment 8

18 years ago
This bug has been quiet for sometime. Is anybody working on it yet? This seems
like a "low cost - high return" type of feature. Please mark it for a sooner
milestone. Thank You.

Comment 9

18 years ago
There are no plans that I know of to work on this in the near future. I'm adding
the helpwanted keyword so that someone who wants to work on mailnews and wants
to implement this feature knows that it exists.
Keywords: helpwanted

Comment 10

18 years ago
OK, if this bug is deemed unimportant, then maybe i am just not understanding
something right about newsgroups.

When I post a reply to another's post (somewhere DEEP inside a newsgroup). And I
then want to see if there is a reply to my comment, how do I relocate that
thread? Assuming that messages are "threaded" (which is very common). Sorting by
name and scrolling through large groups (asside from being tedious) would not
yield my name since it is burried in a thread. Flagging my post will also not
work for the same reason.

It seems to me that marking posts as "WATCHED" and then selecting
"View-Messaged-Watched Messages (unread)"is the only way to effectively track my
posts (or any post of interest).

If i am wrong, and if there is a better way, please let me know.

I apologize for posting this here, but if there is no good way to monitor news
posts, then this serves as a relevant argument for implementing this feature.
(Assignee)

Comment 11

18 years ago
I agree with you about the importance of watch thread for newsgroups. However,
you can use flag and the go next flagged command to find your flagged messages,
and hence the threads with your posts.

Comment 12

18 years ago
I didn't say this was unimportant just that the resources to work on this don't
currently exist.

Comment 13

18 years ago
I've just voted for this bug - I think it's needed to beat Outlook Express
(which has it).  I also make heavy use of the "ignore thread" feature of OE, to
take out spam &c.

Comment 14

18 years ago
This bug should clearly be marked 4xp as this is a Netscape 4.* feature.

The lack of this feature makes it hard to read newsgroup with many active
threads with Mozilla.
(Assignee)

Comment 15

18 years ago
well, then, you'll be happy to know this will be fixed when the performance
branch lands in about 10 days.
Assignee: putterman → bienvenu
Status: ASSIGNED → NEW
(Assignee)

Comment 16

18 years ago
this is fixed - there's no special icon for watched threads, but that's a
separate bug.
Status: NEW → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → FIXED

Comment 17

18 years ago
i can't find it anywhere in the latest build (2001-03-16). When will it land in
a nightly? Will it be selectable in "Message Filters" or where?

Comment 18

18 years ago
Cannot verify this until bug 72279 is fixed.

Comment 19

18 years ago
Linux (2001-03-26-05-mtrunk)
Win32 (2001-03-26-09-mtrunk)
Mac (2001-03-26-12-mtrunk)
Per Laurel's guidance, I am able to verify this bug.
Thanks Laurel.
Here is the Steps:
1. Select Message->Watch Thread
2. View->Messages ->Watched Thread with Unread
Status: RESOLVED → VERIFIED
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.