Closed Bug 1692148 Opened 3 years ago Closed 2 years ago

Page not loading at mobile.fitness-singles.com with ETP set to STRICT

Categories

(Core :: Privacy: Anti-Tracking, defect, P3)

Other
Android
defect

Tracking

()

VERIFIED FIXED
Tracking Status
firefox92 --- verified

People

(Reporter: rbucata, Unassigned)

References

(Blocks 1 open bug, )

Details

Attachments

(1 file)

Attached image Screenshot_8.jpg

Environment:
Operating system: Android 10
Firefox version: :Firefox Nightly 210210 (87.0a1-20210209092956)

Preconditions:
ETP Strict enabled

Steps to reproduce:

  1. Navigate to https://mobile.fitness-singles.com/
  2. Observe the behavior.

Expected Behavior:
The page loads as expected.

Actual Behavior:
The page is stuck in an infinite loading loop.

Notes:
Not reproducible with ETP set to STANDARD

I see Uncaught TypeError: window.google_trackConversion is not a function. We might be able to shim https://www.googleadservices.com/pagead/conversion_async.js to mitigate this.

I've confirmed that adding a trivial shim for that function does work here, and the page loads properly.

This issue still reproduces on Firefox Nightly from 8/2 with GV 92, on Google Pixel (Android 10).

Managed to reproduce this issue on desktop on Firefox Nightly 88.0a1 (2021-02-11) on Windows 10 x64, macOS 11.4 and on Ubuntu 20.04 x64 only with ETP Strict enabled.
The issue is not reproducible on desktop any more on the latest Firefox Nightly 93.0a1 (2021-08-09) and on Firefox 92.0b1 on Windows 10 x64, macOS 11.4 and on Ubuntu 20.04 x64 only with ETP Strict enabled.

The issue is no longer reproducible on 92.0.0-beta.2 with Google Pixel 3 (Android 12) - ETP Strict enabled.

I was not able to reproduce this issue on the 8/23 Nightly 93.0a1 build, nor on Beta 92.0.0-beta.6 anymore.
Tested with Lenovo Tab M10 (Android 10).
I'll close as verified as fixed.

Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.