Can't edit user name and server type of IMAP accounts.

VERIFIED FIXED

Status

SeaMonkey
MailNews: Account Configuration
--
major
VERIFIED FIXED
16 years ago
14 years ago

People

(Reporter: esther, Assigned: Cavin Song)

Tracking

({regression})

Trunk
x86
All
regression

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment, 1 obsolete attachment)

802 bytes, patch
Navin Gupta
: review+
(not reading, please use seth@sspitzer.org instead)
: superreview+
jesup
: approval+
Details | Diff | Splinter Review
(Reporter)

Description

16 years ago
Using trunk builds 20020917 on winxp & linux (haven't tried Mac yet), I can't
edit the user name and server name for my IMAP accounts.  This is regression
from Branch.  Does not happen to POP accounts.

1.) Launch a trunk build
2.) Open mail and and an ISP account that is IMAP.
3.) After account is added, go to Account settings for that account and click on
Sever settings to try to change the server name.

Result:  Server name and user name are not editable fields.
Expected: To be able to edit the server name or user name.
(Reporter)

Comment 1

16 years ago
Nominating, we need this in the next build.  Users can edit their user name and
server with currently released builds, can't take that away.
Keywords: nsbeta1, regression
Summary: Can't edit user name and server type of IMAP accounts. → Can't edit user name and server type of IMAP accounts.
(Reporter)

Comment 2

16 years ago
changing assigned to cavin
Assignee: racham → cavin
QA Contact: nbaca → esther
(Assignee)

Comment 3

16 years ago
Looks like we should check if the redirector type is an empty string as well in 
the js code. A patch is coming.
(Assignee)

Comment 4

16 years ago
Created attachment 99556 [details] [diff] [review]
Proposed patch, v1

Check if the redirector type is an empty string as well
  var showFixedValues = gRedirectorType != null;
+  var showFixedValues = (gRedirectorType != null) && (gRedirectorType != "");

this is enough:

var showFixes = gRedirectorType ? true : false; 

that works for null and "".
(Assignee)

Comment 6

16 years ago
Created attachment 99566 [details] [diff] [review]
Incorporated comment
Attachment #99556 - Attachment is obsolete: true

Comment 7

16 years ago
Comment on attachment 99566 [details] [diff] [review]
Incorporated comment

r=naving
Attachment #99566 - Flags: review+
Comment on attachment 99566 [details] [diff] [review]
Incorporated comment

sr=sspitzer

alternatively, could we have initialized gRedirectory type properly?
Attachment #99566 - Flags: superreview+
(Assignee)

Comment 9

16 years ago
gRedirectorType is initialized in onPreInit() for each selected account:

  gRedirectorType = parent.getAccountValue(...);
(Assignee)

Comment 10

16 years ago
Fix checked in.
(Assignee)

Comment 11

16 years ago
Marking fixed.
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → FIXED
(Reporter)

Comment 12

16 years ago
Using trunk builds 20021029 on linux, 20021028 on winxp and 20021025 on Mac OSX
this is fixed. Verified.
Status: RESOLVED → VERIFIED
This was bugscape 21297, but the fix is this bug and needs drivers approval for
the 1.0.2 branch before check-in
Keywords: adt1.0.2+, mozilla1.0.2
Comment on attachment 99566 [details] [diff] [review]
Incorporated comment

a=rjesup@wgate.com for 1.0 branch; change mozilla1.0.2+ to fixed1.0.2 when
checked in
Attachment #99566 - Flags: approval+

Updated

16 years ago
Keywords: mozilla1.0.2 → mozilla1.0.2+
(Assignee)

Comment 15

16 years ago
Fix checked in to the 1.0 branch.
Keywords: mozilla1.0.2+ → fixed1.0.2
(Reporter)

Comment 16

16 years ago
*** Bug 171221 has been marked as a duplicate of this bug. ***
(Reporter)

Comment 17

16 years ago
Update- Verified on branch build 11-12 on linux, I don't have a MAC OSX 11-12
branch build that has the fix yet. Waiting for my WinXP system to finish up
other testing to see if it's fixed.  
On linux, I tested with existing profile and newly created profile, had 4
different accounts  -all accounts that should be able to edit server was OK. 
(Reporter)

Comment 18

16 years ago
using branch build 11-12-13-2002 on winxp and 11-12-2002 on macosx this is
fixed. changing fixed1.0.2 to verified1.0.2
Keywords: fixed1.0.2 → verified1.0.2
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.