Closed Bug 1692303 Opened 1 year ago Closed 1 year ago

Flip the default value of the browser.ctrlTab.recentlyUsedOrder pref to false, and also change it for people who haven't used Ctrl-Tab.

Categories

(Firefox :: Tabbed Browser, enhancement, P1)

enhancement
Points:
3

Tracking

()

RESOLVED FIXED
89 Branch
Tracking Status
firefox89 --- affected

People

(Reporter: bwinton, Assigned: bigiri)

References

(Blocks 1 open bug)

Details

(Keywords: helpwanted, Whiteboard: [proton-tabs-bar])

Attachments

(1 file)

Full details to be hammered out with Romain in the near future, but I think this is a good first cut at the desired behaviour.
Also, this shouldn't land before 89.

Priority: -- → P1
Severity: -- → S4

(Moving to P2, because it shouldn't block graduating to the main pref, and also shouldn't land before the 89 branch reaches Nightly.)

Priority: P1 → P2
Points: --- → 3

Marking as P1. Per experience review we agreed to mark as P1 bug the ones that will block MR1.

Priority: P2 → P1
Assignee: nobody → bigiri
Status: NEW → ASSIGNED

Changed default Ctrl+Tab preference to false and added UI migration to reset it for users who haven't not used the feature before.

Attachment #9211315 - Attachment description: WIP: Bug 1692303 - Flip default value to browser.ctrlTab.recentlyUsedOrder to false (WIP) r=mstriemer,mconley → Bug 1692303 - Flip default value to browser.ctrlTab.recentlyUsedOrder to false r=mstriemer,mconley
Pushed by bigiri@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/75aeeb931c88
Flip default value to browser.ctrlTab.recentlyUsedOrder to false r=mstriemer,mconley,preferences-reviewers
Status: ASSIGNED → RESOLVED
Closed: 1 year ago
Resolution: --- → FIXED
Target Milestone: --- → 89 Branch

And this broke everyone's pref. 😞
I've left a comment in phabricator about what the bug was. Bernard, please get a fix in ASAP!

Status: RESOLVED → REOPENED
Resolution: FIXED → ---

I can confirm that it broke my pref, I am a heavy user of ctrl+tab yet the value was reset for me.

I'm confused... I feel like this should have been covered by the has_used_ctrl_tab_and_its_on test that bigiri added.

@pascalc, can you tell me what the pref values are for:

  • browser.engagement.ctrlTab.has-used
  • browser.migration.version

?

Flags: needinfo?(pascalc)

I also encountered this. The values for me are are:

  • browser.engagement.ctrlTab.has-used = true
  • browser.migration.version = 108

Though this is after I tried Ctrl-Tab a few times, noticed it wasn't working right, and turned browser.ctrlTab.sortByRecentlyUsed back on. I noticed browser.ctrlTab.migrated was true at the time I flipped the pref back.

I was able to reproduce this with a fresh profile, installed Nightly 2021-03-26-21-51-06, used ctrl-tab, updated to 2021-03-28-09-56-25.

I suspect the issue is because this patch removes the default value for the old pref browser.ctrlTab.recentlyUsedOrder, but tries to read that pref here with defaultValue for the new pref, which is false. In this case it seems like it should have been getBoolPref(oldPrefName, oldDefaultValue), with oldDefaultValue = true.

I have the same values as Adam.

Flags: needinfo?(pascalc)

agashlin found the root cause of this bug and fixed it in bug 1701542. The problem was that we missed the common case in our testing and implementation: the case where the user had used ctrl-tab recently, and had never had a value set for the tab switching preference. Bug 1701542 has landed in central, so anybody who managed to not run any Nightly's between when the original patch landed and the patch in bug 1701542 landed should be okay. It's the Nightly folks who happened to update and run in that 2 day window where they'll have had their preference reset, and I'm afraid there's not much we can do about it. :/

Status: REOPENED → RESOLVED
Closed: 1 year ago1 year ago
Resolution: --- → FIXED
Regressions: 1746804
You need to log in before you can comment on or make changes to this bug.