Closed Bug 169244 Opened 17 years ago Closed 16 years ago

TextArea cannot handle large strings

Categories

(Core :: Layout: Form Controls, defect)

x86
Linux
defect
Not set

Tracking

()

RESOLVED DUPLICATE of bug 56219

People

(Reporter: johnp, Unassigned)

Details

I have XML output in a log file that is around 9942 characters long.  I need to
paste this to a form in order to resubmit it during testing.  I can do this in
Konquerer but Mozilla and Galeon simply don't allow cut and paste data this big.
 If I break it up a bit I can get all bust the last 100 or so characters in.
>
Assignee: alexsavulov → form
Component: Form Submission → Layout: Form Controls
QA Contact: vladimire → tpreston
John, are you still experiencing this problem? Can you reproduce it with a
current copy of mozilla?

What program is the data source for this paste operation?

Bug 155140 comment 6 contains a rather extensive writeup of cutting & pasting
between various applications; there it seemed that gnome applications were the
main source of trouble rather than mozilla.
I can reproduce this on Red Hat 9. I try to copy a large amount of text from any
editor (gvim, gedit, vim, OpenOffice, etc) and it won't paste into a Mozilla
text area. If I only select a small amount of text (say 20 lines of text) it works.

If I open the text file in Mozilla and copy a large amount of text to the text
area it works. I can copy large amounts of text back and forth between all the
available editors on Red Hat 9 but when I try to copy to Mozilla text area it
fails. No error - just nothing - as if there was nothing in the clipboard. I
tried the nightly build (v 1.4b) today and it still doesn't work.
Since over 1 month no answer from the reporter, so closing bug as wfm.
If the bug exists in newer builds (1.4 final) then look for a similar bug or
reopen this bug.

*** This bug has been marked as a duplicate of 56219 ***
Status: UNCONFIRMED → RESOLVED
Closed: 16 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.