A combo box list menu only renders below the widget.

VERIFIED DUPLICATE of bug 16152

Status

()

Core
Layout: Form Controls
P3
normal
VERIFIED DUPLICATE of bug 16152
19 years ago
19 years ago

People

(Reporter: Chris Petersen, Assigned: rods (gone))

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

19 years ago
Build: Apprunner
Version: 1999102008
Platform: All
Expected Results: The combo list menu should above the widget when neccesary. An
example who be if the combo box near the bottom of page.Clicking the combo box
should cause menu list to appear above widget. This prevent the menu from drawing
off the bottom of the screen.

What I got: The menu list is drawn below the widget. In this case, the menu is
drawn partially off the bottom of the screen.


Steps to reproduce:

1) Open the attached test case in apprunner.
2) Position the window so the widget is near the bottom of the screen (monitor).
3) Click and hold mouse over combo box.
4) The menu is drawn partially off the screen. Not all menu items are visible.
(Reporter)

Comment 1

19 years ago
Created attachment 2312 [details]
A select menu with mutiple options.
(Assignee)

Updated

19 years ago
Status: NEW → RESOLVED
Last Resolved: 19 years ago
Resolution: --- → DUPLICATE
(Assignee)

Comment 2

19 years ago
This is a regression, it isn't positioning the listbox above the combobox when
there isn't enough room below.

*** This bug has been marked as a duplicate of 16152 ***

Updated

19 years ago
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.