Closed Bug 1692659 Opened 7 months ago Closed 7 months ago

Lots of errors when opening preferences

Categories

(Thunderbird :: Preferences, defect)

defect

Tracking

(thunderbird_esr78 wontfix)

RESOLVED FIXED
87 Branch
Tracking Status
thunderbird_esr78 --- wontfix

People

(Reporter: mozilla, Assigned: Paenglab)

Details

Attachments

(1 file, 1 obsolete file)

User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:78.0) Gecko/20100101 Firefox/78.0

Steps to reproduce:

  1. Open preferences (Edit->Preferences)

Actual results:

Loads of errors showed up in error console:

OverrideError: An entry font-size-label of type message is already defined in this bundle
OverrideError: An entry window-close-key of type message is already defined in this bundle
OverrideError: An entry startup-label of type message is already defined in this bundle
OverrideError: An entry focus-search-shortcut of type message is already defined in this bundle
OverrideError: An entry close-button of type message is already defined in this bundle
OverrideError: An entry font-size-label of type message is already defined in this bundle
OverrideError: An entry window-close-key of type message is already defined in this bundle
OverrideError: An entry startup-label of type message is already defined in this bundle
OverrideError: An entry focus-search-shortcut of type message is already defined in this bundle
OverrideError: An entry close-button of type message is already defined in this bundle
NotSupportedError: CustomElementRegistry.define: 'conversation-browser' has already been defined as a custom element conversation-browser.js:853
<anonymous> chrome://chat/content/conversation-browser.js:853
<anonymous> chrome://messenger/content/customElements.js:34
<anonymous> chrome://messenger/content/customElements.js:37
observe resource://gre/modules/MailGlue.jsm:201
initHTMLDocument resource:///modules/imThemes.jsm:741
onStateChange chrome://chat/content/conversation-browser.js:62
Empty string passed to getElementById(). 3 browser-custom-element.js:411:22
Empty string passed to getElementById(). 6 browser-custom-element.js:411:22

Expected results:

Standard functionality should not trigger such errors

Thanks Alain, yeah, we should try to get rid of those, especially the conversation-browser error (whereas the localization issues are just warnings).

Confirming for 78.7.1 (64-bit) exactly as described.

Status: UNCONFIRMED → NEW
Ever confirmed: true

regression?

(In reply to Wayne Mery (:wsmwk) from comment #2)

regression?

No idea, sorry. I usually don't look at the error console (too deeply buried... see bug 1691637), and only noticed these while investigating an unrelated problem with my lightning calendars...

Attached patch 1692659-un-double-entities.patch (obsolete) — Splinter Review

This fixes the OverrideErrors with giving different names to the entities that are doubled in different prefs files. Are the new names okay for you?

The other errors are because the chat theme preview can't be loaded. There exists another bug for this.

Assignee: nobody → richard.marti
Status: NEW → ASSIGNED
Attachment #9203070 - Flags: review?(alessandro)

This doesn't happen on trunk or beta?
Do we know why is this affecting only 78?

Definitely changing the fluent IDs to something unique is a good approach, but I'm not sure we want to do that for 78 since we risk to break l10n and this wouldn't be uplifted.

Magnus, do you know why this issue is not showing on trunk, even if the fluent IDs are the same?

Flags: needinfo?(mkmelin+mozilla)

The OverrideErrors happen on Daily too. I haven't planned to fix them on ESR because of the l10n string freeze.

The OverrideErrors happen on Daily too

I can't seem to make it happen.

I haven't planned to fix them on ESR because of the l10n string freeze.

Ah, right, then we don't need to bother Magnus with this.

Flags: needinfo?(mkmelin+mozilla)
Comment on attachment 9203070 [details] [diff] [review]
1692659-un-double-entities.patch

Review of attachment 9203070 [details] [diff] [review]:
-----------------------------------------------------------------

Indeed, using unique and semantically correct IDs it's the way to go.
r+ with a couple of fixes and suggestions.

::: mail/locales/en-US/messenger/preferences/offline.ftl
@@ +8,5 @@
>  autodetect-online-label =
>      .label = Automatically follow detected online state
>      .accesskey = d
>  
> +when-startup-label = Manual state when starting up:

Maybe offline-preference-startup-label?

::: mail/locales/en-US/messenger/preferences/passwordManager.ftl
@@ +5,5 @@
>  saved-logins =
>      .title = Saved Logins
>  window-close =
>      .key = w
> +focus-search-normal-shortcut =

focus-search-primary-shortcut?

::: mail/locales/en-US/messenger/preferences/permissions.ftl
@@ +5,5 @@
>  permissions-reminder-window =
>      .title = Exceptions
>      .style = width: 45em;
>  
> +close-window-key =

permission-preferences-close-window?
If I'm not wrong I think we're not using the `-key` suffix if the ID has the `.key` attribute.
Attachment #9203070 - Flags: review?(alessandro) → review+

Changed the IDs to your proposals. Yes in M-C they don't use the -key suffix. In C-C we have with the suffix but in permissions.ftl it's the only occurrence. So it should be save to change.

Attachment #9203070 - Attachment is obsolete: true
Attachment #9203504 - Flags: review+
Target Milestone: --- → 87 Branch

Pushed by mkmelin@iki.fi:
https://hg.mozilla.org/comm-central/rev/76d45c7536ea
Fix double localization entities in the preferences. r=aleca

Status: ASSIGNED → RESOLVED
Closed: 7 months ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.