[DOGFOOD] when replying to a message with an image, it doesn't show up

VERIFIED FIXED in M11

Status

MailNews Core
Composition
P3
normal
VERIFIED FIXED
18 years ago
10 years ago

People

(Reporter: Scott MacGregor, Assigned: Scott MacGregor)

Tracking

Trunk
Other
Other

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [PDT-])

(Assignee)

Description

18 years ago
This came out of Bug #16814.

If you have an imap or pop message that has an image embedded in it or attached
to it and you hit reply, the compose window comes up and the image isn't part

of the message.

I expect to see the image in the reply area of the message.

For instance, I sent myself a message that just had an image. I then viewed it
in 5.0 and verified that I could see the image in the message pane. I then hit
reply and the compose window came up.


I got the usual: "Scott MacGrgor wrote:" and then everything else was blank.

I'm going to start the guessing game by saying it's a problem with the html
emitter when quoting a msg with an image?

Comment 1

18 years ago
Isn't this the age old URL dispatching problem? I create URL's for these images
that will look like mailbox://.....?part=1.2

Unless I'm mistaken, I didn't think this worked until your Porkjockey work was
done?

- rhp
(Assignee)

Comment 2

18 years ago
Hey Rich, I don't think this has to do with url dispatching. But maybe I'm
mistaken. I mean we can view the message in the message pane and we properly
pass the mailbox://...?part=1.2 into mime and it extracts the message just fine.
This should be the same principal here too. The mailbox url is loaded by the
editor shell which hands it to the mailbox protocol which in turn hands it to
the mime converter which sees the ?part=1.2 and returns that part.


The url dispatching work I'm doing is more geared towards: a user is in a
browser window and they click on a mailto link, we need to dispatch that to a
new window (a compose window). Or you click on an mp3 link, we need to kick the
document out to a helper app.


In this case there is no url dispatching involed because the image needs to be
handled by the window showing the reply message. so no dispatching to a window.

Updated

18 years ago
Status: NEW → ASSIGNED
Target Milestone: M11

Comment 3

18 years ago
Hmm... wierd...wonder what broke. Well, I'll take a look into tonight it after
I finish up the new quoting stuff.

- rhp

Comment 4

18 years ago
Scott,
Will this URI get dispatched correctly?

mailbox_message://rhp@mail.pennatech.com/Inbox#0?header=quotebody&part=1.1.2

This is what is failing in your quoted material.

- rhp
(Assignee)

Comment 5

18 years ago
Rich, I think the reason the image doesn't show up is because we are told the
message doesn't have a body. So the nsMsgQuote code only quotes the headers.

We need to figure out how embedded images are represented in the msgCompFields
for a message (are they listed as an attachment for example?) and then we need
to figure out how we can detect this and make sure the quoting knows to go fetch
it.

Comment 6

18 years ago
Are you sure this isn't a pref you have set. I am getting full bodies quoted
and I can even send you the HTML that is being loaded into composer. I'll email
you the file.

- rhp

Updated

18 years ago
Whiteboard: [PDT-]

Comment 7

18 years ago
There were a of reply-to bugs in 4.x about losing background stuff.. so surely
we can work with this for dogfood usage.  PDT-
Thanks

Comment 8

18 years ago
This isn't just background images...this is ALL images. This is pretty major
and mscott and I have a beat on what the problem is so I don't think it will
take us long to fix it.

- rhp

Updated

18 years ago
QA Contact: lchiang → pmock

Comment 9

18 years ago
changing QA assigned to myself
(Assignee)

Updated

18 years ago
Assignee: rhp → mscott
Status: ASSIGNED → NEW
(Assignee)

Comment 10

18 years ago
Rich and I have been working on a fix for this. We were mixing up rdf uri's with
protocol url strings which is why the images were never loading.

I have a fix in my tree so I'm going to re-assign this to me.
(Assignee)

Updated

18 years ago
Status: NEW → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → FIXED
(Assignee)

Comment 11

18 years ago
I finally got around to flushing this out of my tree and checking it in.

Fix checked in.

To verify, send yourself a message with an image dragged into it (using 4.7) or
attach the image if you are using 5.0. View the msg, make sure you see the image
inline. Then reply to the message. You should see the image get appear in the
quoted body of the message.

Updated

18 years ago
Blocks: 17432

Updated

18 years ago
Status: RESOLVED → VERIFIED

Comment 12

18 years ago
Verified as fixed on win, mac, and linux using the following builds:
ftp://sweetlou/products/client/seamonkey/windows/32bit/x86/1999-11-17-17-M12/sea
monkey32.exe
ftp://sweetlou/products/client/seamonkey/macos/8.x/ppc/1999-11-17-08-M12/netscap
e5-mac-M11.sea.bin
ftp://sweetlou/products/client/seamonkey/unix/linux_glibc/2.2/x86/1999-11-17-17-
M12/netscape-i686-pc-linux-gnu.tar.gz

Updated

18 years ago
No longer blocks: 17432
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.