Closed Bug 1692840 Opened 10 months ago Closed 8 months ago

Add "Open a New Tab" at the top of the tabstrip context menu

Categories

(Firefox :: Tabbed Browser, enhancement, P2)

Desktop
All
enhancement

Tracking

()

VERIFIED FIXED
89 Branch
Tracking Status
firefox89 --- verified

People

(Reporter: Gijs, Assigned: gl)

References

(Depends on 1 open bug, Blocks 1 open bug)

Details

(Keywords: helpwanted, Whiteboard: [proton-context-menus] [priority:2c])

Attachments

(1 file)

Other browsers lead the context menu with this. We've had a few similar requests. We should add a new menuitem called "Open a New Tab" at the top, followed by a menu separator, and it should add a tab immediately to the right of the tab that is clicked on (or at the end of the tabstrip, if you open it from the empty space on the tabstrip).

Severity: -- → N/A
Type: defect → enhancement
Priority: -- → P3
Keywords: helpwanted
Assignee: nobody → gl
Status: NEW → ASSIGNED

As per guidance from Vicky, for tracking, we're marking all the bugs that people are working on as P1.

Priority: P3 → P1
See Also: → 1692667

Marking as P2. Per experience review we agreed to mark as P1 bugs only bugs that will block MR1.

Priority: P1 → P2
Whiteboard: [proton-context-menus] → [proton-context-menus] [priority:2c]
Pushed by gijskruitbosch@gmail.com:
https://hg.mozilla.org/integration/autoland/rev/758854f18b75
Add "Open a New Tab" at the top of the tabstrip context menu. r=Gijs
Status: ASSIGNED → RESOLVED
Closed: 8 months ago
Resolution: --- → FIXED
Target Milestone: --- → 89 Branch

Since the status are different for nightly and release, what's the status for beta?
For more information, please visit auto_nag documentation.

Duplicate of this bug: 1382929
Duplicate of this bug: 1490445
See Also: → 579720

I've already verified New Tab option in bug 1705387 which got fixed after this bug, using latest builds across platforms (Windows 10, Ubuntu 18.04 and macOS 11.3), I'll go ahead and mark this as verified as well,

Status: RESOLVED → VERIFIED
Depends on: 1726540
You need to log in before you can comment on or make changes to this bug.