leave mail on server deletes mail after download

RESOLVED WORKSFORME

Status

MailNews Core
Networking: POP
RESOLVED WORKSFORME
15 years ago
9 years ago

People

(Reporter: Roscoe Primrose, Assigned: Navin Gupta)

Tracking

Trunk
x86
Windows 98

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.2a) Gecko/20020914
Build Identifier: Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.2a) Gecko/20020914

With a pop3 server configured to leave mail on server, all messages still get
deleted on download.  I do NOT have delete messages from server when deleted
locally checked.

Reproducible: Always

Steps to Reproduce:
1.Setup pop3 server to leave messages on server
2.Download mail
3.Check mail with another client (or, ssh into the server and see a 0 byte spool)

Actual Results:  
Mail was downloaded and deleted from server

Expected Results:  
Downloaded mail but left it on the server.

Seeing same behavior with 1.1 as well

Comment 1

15 years ago
I'm getting this bug as well with 1.3a.  Since there seems to be a range of
problems with the option, I figured it might help to include the fact that the
server I'm trying to connect to is running the University of Washington's
IMAP4rev1 software, and I'm connecting through the POP3 wrapper.

Comment 2

15 years ago
Oh, and my brother does not have this problem connecting to the same server
using Outlook (the bastard!) and using their version of this option.

Comment 3

15 years ago
Wait, wait.  I think that this might not be a bug.  It might just be a percieved
bug from end user stand-point.  We're both checking directly on the server, and
it could be that since the POP daemon has read the mail out of the mail queue it
may move it someplace else where a simple program (such as "mail") doesn't know
to look for it.  It may be available from other POP connections.  You should
verify in some way if this is the case for you.

Comment 4

15 years ago
Reporter (Roscoe): what's happening with this?  

Were you able to test as Peep suggested?  

Have you tried a newer version of Mozilla?  

Can you access the same mail account with another client (like a web interface)
and see if the messages are there?

What mail server is your ISP running?

If you can't confirm this is still happening, please resolve the bug as
WORKSFORME.  If you can, please post more details.
(Reporter)

Comment 5

15 years ago
WFM with 2003061108 on OSX...

Comment 6

15 years ago
Reporter (Roscoe): what's happening with this?  

Were you able to test as Peep suggested?  

Have you tried a newer version of Mozilla?  

Can you access the same mail account with another client (like a web interface)
and see if the messages are there?

What mail server is your ISP running?

If you can't confirm this is still happening, please resolve the bug as
WORKSFORME.  If you can, please post more details.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → WORKSFORME
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.