Closed Bug 169359 Opened 18 years ago Closed 12 years ago

Implement IE Style Web Archive Save and Opening

Categories

(Camino Graveyard :: General, enhancement)

PowerPC
macOS
enhancement
Not set

Tracking

(Not tracked)

VERIFIED WONTFIX
Future

People

(Reporter: mikejuni, Unassigned)

References

(Depends on 2 open bugs)

Details

I think that in order for Chimera to become the "default" browser in Mac OS X
without opening IE ever again, implementing IE Style Web Archive is an
enhancement that is quite important.

Currently, IE5, IE6 (PC) saves pages in web archive format, IE5.1.2 in Mac OS X
also saves pages in web archive format. In order to improve usability and
compatibility, it would be nice to have the format of IE style web archive.
Michael, can you provide documentation about that format?
The IE web archive format seems to be a proprietary file format (and knowing
Microsoft, it probably is).

However, IE style (if not IE format) archives could still be a great thing to
have in Chimera.

I think Chimera should save archives as bundles, so a web site along with its
images could be saved as a single double-clickable item, that could still be
edited later (by using Finder's Show Package Contents) if need be.
The Mozilla bug for supporting IE archives is bug 108329. I think it would be
best if we could read files saved in that format, but I also think Lauri's idea
is great for how we save our own archives. There have been many times where I
wanted to get at one file in an archive; packages would be perfect.
Personally, I think this would be a better feature for Mac Mozilla than Chimera
(since Chimera is supposed to be lean and mean), but if we were to implement
such a feature, I think Lauri's suggestion is a much better idea than using
Microsoft's proprietary and uneditable Web Archive format.
IE web archive files are actually called WAFF files (Web Archive File Format) on
the Mac (I think they're called .mht files in Windows). I don't think they have
anything to do with .cab files. WAFF is 100% Microsoft proprietary and readable
only by Internet Explorer and certain versions of Microsoft Word.
BTW, it seems there is a utilty that will allow you to convert a Microsoft Web
Archive into a standard .zip archive:

Web Archive Converter
http://www.clauss-net.de/mac.html#wac

Unfortunately, it's a Classic App though.
http://www.wotsit.org/search.asp?s=archive
Here you have CAB (and MARC) file formats.
I have a bug open to implement a bundle format. Since this bug is to implement
WAFF I won't dupe it. The bug is Bug 183114 and the bundle format I suggest was
invented by Next a long, long time ago, HTMLD (HTML Directory). Changing "HTML
Complete" ala Mozilla over to .htmld looks at first glance to me like a fairly
trivial task since they are almost identical.
Confirming.
Status: UNCONFIRMED → NEW
Ever confirmed: true
.
Assignee: saari → pinkerton
Target Milestone: --- → Future
Is there any reason that Camino would do this itself and not rely on
implementation of one of the Core bugs (bug 64286, bug 18764, bug 40873)?
While Microsoft's archive method (MHTML) is an RFC, a better idea would be a WAR
file that Konqueror produces.  Basically, it's the webpage with associated files
(images, css, js, etc...) in a folder, all targz'ed.  Much better - more in line
with OOo, rtfd, and others.
(In reply to comment #12)
> Is there any reason that Camino would do this itself and not rely on
> implementation of one of the Core bugs (bug 64286, bug 18764, bug 40873)?

I don't see why, no. Adding those three bugs as dependencies since we'll probably have to change *something* on our end if/when they get implemented.
Depends on: 18764, 40873, 64286
QA Contact: winnie → general
MacIE is dead; if we use an existing bundle format it would be Safari's (bug 294105), so WONTFIXing in favor of that.
Status: NEW → RESOLVED
Closed: 12 years ago
Resolution: --- → WONTFIX
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.