Closed Bug 1693924 Opened 7 months ago Closed 6 months ago

Crash in [@ CompositeYUV]

Categories

(Core :: Graphics: WebRender, defect)

Unspecified
Windows 10
defect

Tracking

()

RESOLVED DUPLICATE of bug 1695782
Tracking Status
firefox-esr78 --- unaffected
firefox85 --- unaffected
firefox86 --- unaffected
firefox87 --- disabled
firefox88 --- affected

People

(Reporter: aryx, Unassigned)

References

(Blocks 1 open bug, Regression)

Details

(Keywords: crash, regression)

Crash Data

10 crashes on 9+ different machines.

Crash report: https://crash-stats.mozilla.org/report/index/d381bc6c-3b59-49c2-859c-68c710210218

Reason: EXCEPTION_ACCESS_VIOLATION_WRITE

Top 9 frames of crashing thread:

0 xul.dll CompositeYUV gfx/wr/swgl/src/composite.h:1065
1 xul.dll webrender::compositor::sw_compositor::SwCompositeThread::process_job gfx/wr/webrender/src/compositor/sw_compositor.rs:678
2 xul.dll std::sys_common::backtrace::__rust_begin_short_backtrace<closure-0, tuple<>> ../cb75ad5db02783e8b0222fee363c5f63f7e2cf5b/library/std/src/sys_common/backtrace.rs:125
3 xul.dll core::ops::function::FnOnce::call_once<closure-0, tuple<>> ../cb75ad5db02783e8b0222fee363c5f63f7e2cf5b/library/core/src/ops/function.rs:227
4 xul.dll std::sys::windows::thread::{{impl}}::new::thread_start ../cb75ad5db02783e8b0222fee363c5f63f7e2cf5b//library/std/src/sys/windows/thread.rs:56
5 kernel32.dll BaseThreadInitThunk 
6 mozglue.dll patched_BaseThreadInitThunk mozglue/dllservices/WindowsDllBlocklist.cpp:591
7 ntdll.dll RtlUserThreadStart 
8 kernelbase.dll TerminateProcessOnMemoryExhaustion 
Flags: needinfo?(lsalzman)
Flags: needinfo?(lsalzman)
Regressed by: sw-wr-perf-linear
No longer regressed by: sw-wr-perf-brush-yuv
Duplicate of this bug: 1695151
Crash Signature: [@ CompositeYUV] → [@ CompositeYUV] [@ linear_row_yuv<T>]
Severity: -- → S3
Crash Signature: [@ CompositeYUV] [@ linear_row_yuv<T>] → [@ CompositeYUV] [@ linear_row_yuv<T>]

High volume in 88 Nightly on Windows.

Blocks: gfx-triage

There have been no crashes on nightly since 20210310093927

Probably fixed by bug 1695782

Status: NEW → RESOLVED
Closed: 6 months ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1695782
No longer blocks: gfx-triage
You need to log in before you can comment on or make changes to this bug.