proportional scrollbar thumb needs minimum size (too small for long content)

RESOLVED WORKSFORME

Status

()

Core
XUL
RESOLVED WORKSFORME
16 years ago
10 years ago

People

(Reporter: m_mozilla, Assigned: jag (Peter Annema))

Tracking

Trunk
PowerPC
Mac OS X
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
copied from
    http://bugzilla.mozilla.org/show_bug.cgi?id=103981#c17
as I'd misunderstood that bug and posted this as a comment in that one instead
of creating a new bug.

I'm seeing this bug in the URL bar's dropdown. Example:

    slashdot.org

gives me a *huge* autocomplete list, and I don't see *any* scrollbar thumb in
that list. If I type

    slashdot.org/article

then my thumb is visible (about five pixels tall) because the list is shorter.
If I type

    slashdot.org/article.pl?sid=02/08

then my proportional thumb is about half the height of the scrollbar 'elevator
shaft'.

The problem is that proportional scrollbar thumbs need to have a minimum size
(and do in non-mozilla apps). I'm going to update the summary. If folks decide I
should not have, the original was:

    scrollbar thumb is too small,
    so double-clicking scrollbar sometimes returns to initial position

I'm on mac os x trunk build 2002091603

-matt

Comment 1

16 years ago
This might be related to bug 106128, which is - on the other hand - only for
mailnews, but the fix might be similar or just the same.

Comment 2

10 years ago
see this ?
Status: NEW → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.