Status in trunk versus 1.0 branch

RESOLVED INVALID

Status

()

bugzilla.mozilla.org
General
--
enhancement
RESOLVED INVALID
15 years ago
6 years ago

People

(Reporter: Greg Colyer, Assigned: Dawn Endico)

Tracking

Details

(Reporter)

Description

15 years ago
Forgive me if (as a relative Bugzilla newbie) I have overlooked something that
already exists, but it's not generally obvious to me whether statuses (such as
"FIXED") apply only to the trunk, or to 1.0 as well, or what. In particular, if
a bug is present in 1.0.1 but not in 1.1 (so has perhaps been fixed since 1.0
branched off), or vice versa, should it still be reported? Is there a mechanism
for requesting that a fix be transferred from branch to trunk, or vice versa, or
a mechanism for requesting that a fix NOT be so transferred? (I am aware that
there is a mechanism whereby such transfers HAPPEN; I am asking specifically
about feedback, from users such as myself.)

Consider this an enhancement request if not.

Comment 1

15 years ago
If a bug has already been reported, it will be in Bugzilla.  There are various
keywords that track whether the bug is fixed on various branches and the trunk.

If you have found a bug in 1.0.1 that isn't present in 1.1, it may be because a
fix was applied to the trunk but hasn't been transferred to the branch.  This
may be trivial to do, or it may not.  You should be able to tell by looking in
the bug's comments whether it will be going into the stable 1.0 branch
(generally, only correctness and stability bugs will go into the 1.0 branch).

If you can't find an existing bug report and the bug exists only on the 1.0
branch, report it by all means, but make it clear that it's for the 1.0 branch only.

This kind of question should be asked in the newsgroups, not a bug report.
-> INVALID
Status: NEW → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → INVALID
Component: Bugzilla: Other b.m.o Issues → General
Product: mozilla.org → bugzilla.mozilla.org
You need to log in before you can comment on or make changes to this bug.