Closed Bug 1694344 Opened 2 months ago Closed 2 months ago

--with-ccache is busted

Categories

(Firefox Build System :: General, defect)

x86_64
Linux
defect

Tracking

(firefox-esr78 unaffected, firefox86 unaffected, firefox87 unaffected, firefox88 fixed)

RESOLVED FIXED
88 Branch
Tracking Status
firefox-esr78 --- unaffected
firefox86 --- unaffected
firefox87 --- unaffected
firefox88 --- fixed

People

(Reporter: fredbezies, Assigned: glandium)

References

(Blocks 1 open bug, Regression)

Details

(Keywords: regression)

Attachments

(1 file)

After updating my copy of the source code of Mozilla Firefox, I got an build error in configure step. Using ./mach busted, I got this output:

./mach build
*** failed to import extension evolve: No module named 'evolve'
*** failed to import extension bzexport from /home/fred/.mozbuild/version-control-tools/hgext/bzexport: [Errno 2] No such file or directory: '/home/fred/.mozbuild/version-control-tools/hgext/bzexport'
*** failed to import extension reviewboard from /home/fred/.mozbuild/version-control-tools/hgext/reviewboard/client.py: [Errno 2] No such file or directory: '/home/fred/.mozbuild/version-control-tools/hgext/reviewboard/client.py'
 0:01.01 Failed to parse ccache stats output: secondary config (readonly)         /etc/ccache.conf
 0:01.02 Clobber not needed.
 Config object not found by mach.
 0:01.03 /home/fred/.mozbuild/_virtualenvs/mach/bin/python /home/fred/logs/fox/src/configure.py
 0:01.34 Re-executing in the virtualenv
 0:01.69 Adding configure options from /home/fred/logs/fox/src/.mozconfig
 0:01.70   --enable-application=browser
 0:01.70   --enable-optimize
 0:01.70   --with-ccache
 0:01.70   --disable-debug
 0:01.70   --disable-tests
 0:01.70   --disable-warnings-as-errors
 0:01.70   --disable-debug-symbols
 0:01.70   --enable-rust-simd
 0:01.70   --with-branding=browser/branding/nightly
 0:01.70   --enable-default-toolkit=cairo-gtk3-wayland
 0:01.70   --disable-updater
 0:01.70   --enable-release
 0:01.70   RANLIB=llvm-ranlib
 0:01.70   CXX=clang++
 0:01.70   NM=llvm-nm
 0:01.70   AR=llvm-ar
 0:01.70   CC=clang
 0:01.70   MACH_USE_SYSTEM_PYTHON=1
 0:01.70 checking for vcs source checkout... hg
 0:01.77 checking for a shell... /usr/bin/sh
 0:01.85 checking for host system type... x86_64-pc-linux-gnu
 0:01.85 checking for target system type... x86_64-pc-linux-gnu
 0:02.19 checking whether cross compiling... no
 0:02.28 checking for Python 3... /home/fred/logs/fox/objdir-fx/_virtualenvs/init_py3/bin/python (3.9.2)
 0:02.28 checking for hg... /usr/bin/hg
 0:02.43 checking for Mercurial version... 5.7
 0:02.65 checking for sparse checkout... no
 0:02.66 checking for wget... /usr/bin/wget
 0:02.66 Traceback (most recent call last):
 0:02.66   File "/home/fred/logs/fox/src/configure.py", line 231, in <module>
 0:02.66     sys.exit(main(sys.argv))
 0:02.66   File "/home/fred/logs/fox/src/configure.py", line 55, in main
 0:02.66     sandbox.run(os.path.join(os.path.dirname(__file__), "moz.configure"))
 0:02.66   File "/home/fred/logs/fox/src/python/mozbuild/mozbuild/configure/__init__.py", line 563, in run
 0:02.66     func(*args)
 0:02.66   File "/home/fred/logs/fox/src/python/mozbuild/mozbuild/configure/__init__.py", line 614, in _value_for
 0:02.66     return self._value_for_depends(obj)
 0:02.67   File "/home/fred/logs/fox/src/python/mozbuild/mozbuild/util.py", line 1049, in method_call
 0:02.67     cache[args] = self.func(instance, *args)
 0:02.67   File "/home/fred/logs/fox/src/python/mozbuild/mozbuild/configure/__init__.py", line 623, in _value_for_depends
 0:02.67     value = obj.result()
 0:02.67   File "/home/fred/logs/fox/src/python/mozbuild/mozbuild/util.py", line 1049, in method_call
 0:02.67     cache[args] = self.func(instance, *args)
 0:02.67   File "/home/fred/logs/fox/src/python/mozbuild/mozbuild/configure/__init__.py", line 162, in result
 0:02.67     return self._func(*resolved_args)
 0:02.67   File "/home/fred/logs/fox/src/python/mozbuild/mozbuild/configure/__init__.py", line 1298, in wrapped
 0:02.67     return new_func(*args, **kwargs)
 0:02.67   File "/home/fred/logs/fox/src/build/moz.configure/util.configure", line 441, in wrapper
 0:02.67     return func(*args)
 0:02.67   File "/home/fred/logs/fox/src/python/mozbuild/mozbuild/configure/__init__.py", line 1298, in wrapped
 0:02.67     return new_func(*args, **kwargs)
 0:02.67   File "/home/fred/logs/fox/src/build/moz.configure/toolchain.configure", line 681, in <lambda>
 0:02.67     "sccache", when=depends_if("CCACHE")(lambda c: c[0] == "sccache")
 0:02.67 IndexError: tuple index out of range
*** failed to import extension evolve: No module named 'evolve'
*** failed to import extension bzexport from /home/fred/.mozbuild/version-control-tools/hgext/bzexport: [Errno 2] No such file or directory: '/home/fred/.mozbuild/version-control-tools/hgext/bzexport'
*** failed to import extension reviewboard from /home/fred/.mozbuild/version-control-tools/hgext/reviewboard/client.py: [Errno 2] No such file or directory: '/home/fred/.mozbuild/version-control-tools/hgext/reviewboard/client.py'
*** failed to import extension evolve: No module named 'evolve'
*** failed to import extension bzexport from /home/fred/.mozbuild/version-control-tools/hgext/bzexport: [Errno 2] No such file or directory: '/home/fred/.mozbuild/version-control-tools/hgext/bzexport'
*** failed to import extension reviewboard from /home/fred/.mozbuild/version-control-tools/hgext/reviewboard/client.py: [Errno 2] No such file or directory: '/home/fred/.mozbuild/version-control-tools/hgext/reviewboard/client.py'
Error running mach:

    ['build']

The error occurred in code that was called by the mach command. This is either
a bug in the called code itself or in the way that mach is calling it.
You can invoke |./mach busted| to check if this issue is already on file. If it
isn't, please use |./mach busted file build| to report it. If |./mach busted| is
misbehaving, you can also inspect the dependencies of bug 1543241.

If filing a bug, please include the full output of mach, including this error
message.

The details of the failure are as follows:

Exception: Process executed with non-0 exit code 1: ['/home/fred/.mozbuild/_virtualenvs/mach/bin/python', '/home/fred/logs/fox/src/configure.py']

  File "/home/fred/logs/fox/src/python/mozbuild/mozbuild/build_commands.py", line 146, in build
    return driver.build(
  File "/home/fred/logs/fox/src/python/mozbuild/mozbuild/controller/building.py", line 1143, in build
    config_rc = self.configure(
  File "/home/fred/logs/fox/src/python/mozbuild/mozbuild/controller/building.py", line 1528, in configure
    status = self._run_command_in_objdir(
  File "/home/fred/logs/fox/src/python/mozbuild/mozbuild/base.py", line 897, in _run_command_in_objdir
    return self.run_process(cwd=self.topobjdir, **args)
  File "/home/fred/logs/fox/src/python/mach/mach/mixin/process.py", line 176, in run_process
    raise Exception(

Sentry event ID: dfc7beb5b80647ddb1d300b5e4d89a43
Sentry is attempting to send 0 pending error messages
Waiting up to 2 seconds
Press Ctrl-C to quit
Regressed by: 1693689
Summary: ./mach build is stopped in the configure step. → --with-ccache is busted

You can work around with --with-ccache=ccache.

Because --with-ccache without a value fulfills a @depends_if, we need to
check for the length. And because we check the length, we can just use a
@depends.

Assignee: nobody → mh+mozilla
Status: NEW → ASSIGNED
Pushed by mh@glandium.org:
https://hg.mozilla.org/integration/autoland/rev/972015c5c2a6
Fix --with-ccache after bug 1693689. r=firefox-build-system-reviewers,sheehan,mhentges
Status: ASSIGNED → RESOLVED
Closed: 2 months ago
Resolution: --- → FIXED
Target Milestone: --- → 88 Branch

Set release status flags based on info from the regressing bug 1693689

You need to log in before you can comment on or make changes to this bug.