Installer displays percentages > 100% when using HTTP



16 years ago
9 years ago


(Reporter: timeless, Assigned: dveditz)


Windows 98

Firefox Tracking Flags

(Not tracked)



(2 attachments)



16 years ago
(from my dad)
Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.0.1) Gecko/20020823 Netscape/7.0

A. He did a full install
... as it approached 100%, we decided to watch it complete, since after all,
when you get near 100%, you're nearly done, right?

well, 100% came, 101% came and then we started worrying, how much longer might
it take?
we didn't know how many packages were left. At this point he considered
cancelling the install because it could take forever ...
So I cheated and looked in the manifest and found out where we were and guessed
how much was left, but we were still in for further surprises...

I suspect that this is a
0. ( packaging bug as well as an installer bug. (if someone from can fix the netscape 7.0 win32 downloading installer that'd be good...)
1. the installer should be smart enough to ask the server for file sizes and use
them instead of the sizes it has in its package (this bug belongs to

related: bug 85716 and bug 83533 which should have been fixed long before n7.0

Comment 1

16 years ago
Created attachment 99667 [details]
113% complete

Comment 2

16 years ago
I tend to say invalid or move to bugscape...:)

I've never seen this with mozilla

Comment 3

16 years ago
this bug report as is is invalid. netscape 7 != mozilla. either file other bug
reports on specific issues concerning the mozilla installer or file bugs at
Last Resolved: 16 years ago
Resolution: --- → INVALID
Henrik, a better solution might be to move such bugs to the Derivatives/Netscape

Comment 5

16 years ago
do you want me to forge a mozilla1.0.x manifest to reproduce this bug?
i believe that problem 1 as outlined here is a bug in mozilla's packager,
however i wouldn't mind if a copy of this bug (preferably without this comment)
was entered into bugscape, I don't have access to bugscape and i don't think
that it's easy to submit a picture through netscape's feedback system.
Resolution: INVALID → ---

Comment 6

16 years ago
I experienced this on Mozilla with today's net installer build (2002100208, I 
think). Will attach screenshot.

I don't know whether this is important or not, but I also always got a message 
about there being too many download errors in inspector.xpi . But I think it 
was xpcom.xpi that was causing the strange percentages: the installer thought 
it was something less than 1Mb (as it should be), but it somehow dowloaded 
about 15Mb's worth of it.

Comment 7

16 years ago
Created attachment 101535 [details]
This bug in Mozilla (2002100208)

Screenshot of net installer showing 223% complete.

Comment 8

16 years ago
what about just fixing it the easy way:

if percent > 100 then
  percent = 100

Comment 9

16 years ago
The problem isn't really the percentage, it's the expected size to download
in the mozilla example we have:

24112 of 10805 <- this number here contributes to the bad percentage.

That second number should be fixed first. If it's fixed then the percentage
would just be right.   We need to have good manifests and good servers. We
should ask the server for the size of all of the files before we start
downloading and using them to calculate the total size. For any places where the
server refuses to give a size, we can use the manifest sizes.
Summary: Netscape 7.0 Installer displays percentages > 100% when using HTTP → Installer displays percentages > 100% when using HTTP
*** Bug 221895 has been marked as a duplicate of this bug. ***
Product: Browser → Seamonkey

Comment 11

13 years ago
*** Bug 316336 has been marked as a duplicate of this bug. ***


12 years ago
QA Contact: bugzilla → general
Seamonkey and Firefox are using a new NSIS based installer. resolving this old bug, please reopen if you still get this with the new installer
Last Resolved: 16 years ago9 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.