Mozilla hangs when loading a particular web page

RESOLVED WORKSFORME

Status

SeaMonkey
General
RESOLVED WORKSFORME
16 years ago
13 years ago

People

(Reporter: ken hamilton, Assigned: asa)

Tracking

Trunk
x86
Windows NT

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

16 years ago
User-Agent:       Mozilla/5.0 (Windows; U; WinNT4.0; en-US; rv:1.1) Gecko/20020826
Build Identifier: Mozilla/5.0 (Windows; U; WinNT4.0; en-US; rv:1.1) Gecko/20020826

Running Mozilla 1.1 on Windows NT, I attempt to load:

http://thompsonelementary.com

This freezes up Mozilla, and I must kill it via the task manager.
Both Opera 5.11 and Netscape 4.7 both load the page.

Reproducible: Always

Steps to Reproduce:
1.
2.
3.

Comment 1

16 years ago
WFM, current CVS, Linux. The page has some java applets on it.
Are you sure you waited long enough to make them load?
Which version of Java are you using?
(Reporter)

Comment 2

16 years ago
I'm using Java Plug-in 1.3.1_02 with Mozilla.  Internet Explorer 5.5 with the
same plug-in has no apparent problems.  (It is not clear which Java version
Netscape 4.7 and Opera 5.11 are using, but probably not 1.3.1_02, otherwise I
would expect the Java console to appear in accordance with my settings.)

The same hang I see using Mozilla 1.1 is reproducible with Netscape 6.2.

I don't think it is simply a matter of slow-loading applets.  It seems more
related to there being multiple applets on the page.  Each button is a separate
applet.  There appears to be a brief artifact as Mozilla tries to render the
first button, but it immediately hangs there.  Five to ten minutes, still no
change.  IE loads up all the buttons lickety split.

(Reporter)

Comment 3

16 years ago
Some further information, which muddies the waters:  I tested this on my home
system (Windows95 OSR2, Java VM 1.3.1, and Mozilla 1.1).  The hang did not occur.

So it appears that this problem may be specific to the environment of my Windows
NT 4.0 system.  I find that Mozilla 1.1 with JVM 1.3.1_02 runs okay on typical
one-applet pages, but this particular page with its multiple applets is a
peculiar problem.  Maybe this all comes down to some Windows NT flakiness. 

Comment 4

16 years ago
WFM on XP too 2002091904, Java Plug-in 1.4.0_01
It's a very CPU intensive page while Java loads there - it takes 99 to 100% cpu
for a few minutes here - but eventually loads and all is well. (P4/1.8)

Comment 5

15 years ago
WFM 20021130 Java 1.4.1

Ken, can you reproduce the bug with a new build and a new JDK?
(Reporter)

Comment 6

15 years ago
I'm happy to report that the problem seems to be well resolved with Mozilla
1.2b, still running with the older 1.3.1 Java plug-in.  I cannot test with the
1.4.x plug-in because we are currently supporting our product on 1.3.1, and we
are seeing an apparent regression with 1.4.x.  But no need for further
confirmation, I think, since the results are excellent with older plug-in.  I
would support closing this issue as "fixed".

Comment 7

15 years ago
Glad to hear it.

Resolving
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → WORKSFORME
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.