If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

editorshell is obsolete; transition to editor (charsetOverlay.js)

VERIFIED DUPLICATE of bug 169029

Status

()

Core
Editor
VERIFIED DUPLICATE of bug 169029
15 years ago
15 years ago

People

(Reporter: Kathleen Brade, Assigned: Kathleen Brade)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Assignee)

Description

15 years ago
http://lxr.mozilla.org/seamonkey/source/xpfe/global/resources/content/charsetOverlay.js#109
uses "editorshell"
EditorShell is obsolete and will be going away at some point (soon).
This bug is to track the changes in charsetOverlay.js related to
editorshell transition to editor.

Comment 1

15 years ago
Should somebody else own this bug? I certainly can fix the problem but I need to
learn from somebody or spend time reading the code. It might be a simple issue
for people who already understand the change. 

Comment 2

15 years ago
We are moving many commands from nsIEditorShell into nsIEditingSession.
I think the "LoadUrl()" is likely one of them, but that work isn't done yet.
Kathy is the better candidate to fix this.
Assignee: shanjian → brade
(Assignee)

Comment 3

15 years ago
cc shanjian since it's like he'll need to review/approve the change (when it
does happen) since this is out of mozilla/editor area.
Status: NEW → ASSIGNED

Comment 4

15 years ago
This will be fixed as part of bug 169029.

*** This bug has been marked as a duplicate of 169029 ***
Status: ASSIGNED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE
(Assignee)

Comment 5

15 years ago
verified with lxr
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.