Closed Bug 1695661 Opened 9 months ago Closed 9 months ago

Context menus are misplaced if they are opened while Firefox window is placed on the screen edges

Categories

(Firefox :: Menus, defect)

Firefox 88
defect

Tracking

()

RESOLVED DUPLICATE of bug 1692081
Tracking Status
firefox88 --- affected

People

(Reporter: emilghitta, Unassigned)

References

(Blocks 2 open bugs)

Details

(Whiteboard: [proton-context-menus])

Attachments

(1 file)

Attached image contextMenu.gif

Affected versions

  • Firefox 88.0a1 (BuildId:20210301093612)

Affected platforms

  • Windows 10 64bit

Unaffected platforms

  • macOS 10.14
  • Ubuntu 20.04

Steps to reproduce

  1. Launch Firefox.
  2. Enable proton context menu.
  3. Reposition the Firefox window near the bottom, left or right screen edges.
  4. Right click on the: Address Bar, Toolbar options or inside the page content.

Expected result

  • The context menu is displayed near the mouse cursor.

Actual result

  • The context menu is misplaced.

Regression Range

  • I don’t think that this is a regression.

Notes

  • For further information regarding this issue please observe the attached screencast.
  • This issue is only reproducible with proton enabled.
  • This issue seems to be reproducible with all (in scope) context menus.

We're still in the process of fixing this in bug 1692081.

Status: NEW → RESOLVED
Closed: 9 months ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1692081
You need to log in before you can comment on or make changes to this bug.