newer version of mozilla (1.0.1) doesnt display Arabic pages well

RESOLVED WORKSFORME

Status

()

Core
Layout: Text
RESOLVED WORKSFORME
15 years ago
9 years ago

People

(Reporter: Samir, Assigned: mkaply)

Tracking

Trunk
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

15 years ago
Version 1.0 of the mozilla browser had pages written in Arabic displayed
perfectly.This isent the case with the new version of the browser (1.0.1) as it
suffers the same problem found in versions prior to 1.0 , please have a look at
www.aljazeera.net using version 1.0 (which shows the page with no problem) and
the newer 1.0.1 version as it may serve as a good example of the problem .

Comment 1

15 years ago
Reporter: try deleting compreg.dat
Does that fix the problem for you?
Summary: newer version of mozilla (1.0.1) doesnt display Arabic pages well → newer version of mozilla (1.0.1) doesnt display Arabic pages well
Are you sure you are comparing 1.01 with 1.0? All versions from the 1.0 branch
have a problem with the layout of Arabic script, which is fixed in the trunk
(bug 138097), so perhaps you are comparing 1.01 with 1.1?

Comment 3

15 years ago
using http://www.al-jazeera.net as a test page: compared to MS-IE, the mozilla
browser doesn´t show all the links and images of the page. (Mozilla 1.2a)

Comment 4

15 years ago
delrop,

Many problems on aljazeera.net are caused by Mozilla's lack of "document.all"
support. The non-standrad Document.all is used everywhere on their site. For
example, take a look at their menu links functions at
http://www.aljazeera.net//j-scripts/menu.js  

See Bug 74201 for more info. 
See also evangelism bug 126524

Comment 6

15 years ago
Reporter can you reproduce this bug with a newer build (1.4 final)?
If not, then please close this bug as worksforme. Thanks.
No response in > 3 months; resolving WFM.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → WORKSFORME

Updated

9 years ago
Component: Layout: BiDi Hebrew & Arabic → Layout: Text
QA Contact: zach → layout.fonts-and-text
You need to log in before you can comment on or make changes to this bug.