[MachO] Composer crashes on Save

VERIFIED FIXED

Status

()

Core
XPCOM
--
critical
VERIFIED FIXED
16 years ago
16 years ago

People

(Reporter: FZiegler, Assigned: Conrad Carlen (not reading bugmail))

Tracking

({crash, dataloss})

Trunk
PowerPC
Mac OS X
crash, dataloss
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

16 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X; en-US; rv:1.1b) Gecko/20020904
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X; en-US; rv:1.1b) Gecko/20020904

Observed on Mach-O builds 2002-09-04-07 and 2002-09-11-07, running on Mac OS X
10.1.5. (CFM builds seem unaffected.)

Reproducible: Always

Steps to Reproduce:
  1. Select File > New > Composer Page
  2. Type in some text
  3. Select File > Save
  4. Enter title "test", click `OK'
  5. Click `Save' 

Actual Results:  
Mozilla crashes (stack trace follows)

Expected Results:  
Mozilla saves the page as `test.html'
(Reporter)

Updated

16 years ago
Status: UNCONFIRMED → NEW
Ever confirmed: true
Keywords: crash, dataloss
(Reporter)

Comment 1

16 years ago
Created attachment 99796 [details]
Stack trace

Comment 2

16 years ago
This needs conrad to land some stuff on the trunk, I think.
Assignee: syd → ccarlen
Component: Editor: Composer → XPCOM
(Assignee)

Comment 3

16 years ago
> This needs conrad to land some stuff on the trunk, I think.

Yep. Code in the file picker is commnted out for Mach-0 due to lack of
nsILocalFileMac. Should be landing it in a few days.
(Reporter)

Updated

16 years ago
Depends on: 118203
(Assignee)

Comment 4

16 years ago
Fixed by bug 172018.
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → FIXED

Comment 5

16 years ago
hysterion, please verify this when you get a chance and mark verified-fixed...
(Reporter)

Comment 6

16 years ago
Verified. Thanks!
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.