Closed Bug 1696130 Opened 1 year ago Closed 4 months ago

Handle errors from calling mozStorageTransaction::Start

Categories

(Core :: Networking: Cookies, task, P3)

task

Tracking

()

RESOLVED DUPLICATE of bug 1696129

People

(Reporter: janv, Unassigned)

Details

Bug 1695883 added a new mandatory method mozStorageTransaction::Start. Some logic may accidentally or intentionally be depending on failure to create a transaction not causing an error, so we currently only warn when mozStorageTransaction::Start fails in netwerk/cookie. Long term, we should handle the error.

Summary: Propagate errors from calling mozStorageTransaction::Start → Handle errors from calling mozStorageTransaction::Start
Status: NEW → RESOLVED
Closed: 4 months ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1696129
You need to log in before you can comment on or make changes to this bug.