Closed Bug 1696214 Opened 11 months ago Closed 8 months ago

Wrong tooltip for tab actions

Categories

(Firefox :: Tabbed Browser, defect, P3)

defect

Tracking

()

VERIFIED FIXED
91 Branch
Tracking Status
firefox91 --- verified

People

(Reporter: ntim, Assigned: enndeakin)

References

Details

(Keywords: helpwanted, Whiteboard: [proton-tooltips])

Attachments

(2 files)

Attached image Screenshot

Tab actions seem to be re-using the rich tooltip instead of the normal one.

Whiteboard: [proton-tabs-bar]
Severity: -- → S3
Priority: -- → P3
Whiteboard: [proton-tabs-bar] → [proton-tooltips]
Assignee: nobody → enndeakin
Status: NEW → ASSIGNED
Blocks: 1695900

This involves changing moveToAnchor to be allowed while the popup is showing. This change allows the buttons within the tab to use the normal algorithm for determining the tooltip position. This also fixes bug 1695900 so that tooltips for items in bookmarks menus also appear offset as well. Only the main tab and bookmarks on the toolbar appear aligned with the button's bottom edge.

Blocks: 1695043
Blocks: 1695527
Blocks: 1695239
Attachment #9222726 - Attachment description: WIP: Bug 1696214, use moveToAnchor to position the tab and places tooltips so that the close and mute button tooltips appear correctly, r=jaws → Bug 1696214, use moveToAnchor to position the tab and places tooltips so that the close and mute button tooltips appear correctly, r=jaws
Pushed by neil@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/de40c72ddc80
use moveToAnchor to position the tab and places tooltips so that the close and mute button tooltips appear correctly, r=jaws
Status: ASSIGNED → RESOLVED
Closed: 8 months ago
Resolution: --- → FIXED
Target Milestone: --- → 91 Branch

Hello I have managed to reproduce the issue with Firefox88.0a1 (2021-03-01) on Windows 10 and I can confirm that the issue is fixed using Firefox 91.0a1 (2021-06-01) on all OS's.

Thank you!

Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.