Closed Bug 1696267 Opened 3 years ago Closed 3 years ago

Typing a trailing space causes search history and suggestions that match the input/heuristic query to go from hidden to shown

Categories

(Firefox :: Address Bar, defect, P3)

defect
Points:
2

Tracking

()

VERIFIED FIXED
88 Branch
Iteration:
88.1 - Feb 22 - Mar 7
Tracking Status
firefox-esr78 --- unaffected
firefox86 --- wontfix
firefox87 --- wontfix
firefox88 --- verified

People

(Reporter: adw, Assigned: adw)

References

(Blocks 1 open bug, Regression)

Details

(Keywords: papercut, regression)

Attachments

(1 file)

STR

  1. Do a search for "testing"
  2. Type "testing" again but don't hit enter
  3. Verify that your "testing" search history is not shown
  4. Type a trailing space

The "testing" search history is shown again, but it shouldn't be.

AFAICT we don't properly dedupe remote suggestions in this context either, but it's unlikely an engine would actually return a suggestion that is the trimmed version of the search string.

Adrian found this in bug 1694237 comment 12. It should be an easy fix, so I'll go ahead and do it now.

This is not a (recent) regression and goes back to at least 78 according to Adrian.

This also fixes a potential problem when deduping SERPs against form history:
We're creating SERP URLs based on the lowercased version of SERP terms instead
of the terms as is. That means we won't detect example.com/?q=foo and
example.com/?q=FOO as being dupes, but I think we should.

I updated the test to check for leading/trailing spaces as well as case.

This is not a (recent) regression and goes back to at least 78 according to Adrian.

Sad to say that Adrian was a bit wrong (my statement was that it is reproducible back to 78-81), but again, I wasn't looking specific to this particular bug. So, the mozregression points to Bug 1645324 - Move the omnibox heuristic result to the omnibox provider. r=adw, which IMO fits the regressor description.

Has Regression Range: --- → yes
Pushed by dwillcoxon@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/8857f3757686
Dedupe urlbar search suggestions and search history accounting for leading and trailing spaces. r=mak
Status: ASSIGNED → RESOLVED
Closed: 3 years ago
Resolution: --- → FIXED
Target Milestone: --- → 88 Branch

Is this worth uplifting to 87 or should it ride the trains?

I think this should just ride the trains because:

  • This goes back to 80 so it's not super urgent
  • This isn't really a huge bug to begin with
  • The patch is pretty simple but it touches code that's complex so there's a (probably small) possibility of introducing subtle bugs
  • We're already in late beta
Flags: needinfo?(adw)

I've reproduced the issue using Fx88.0a1.
The issue is verified fixed in Fx88.0b9 and Fx89.0a1 on Windows 10 and Ubuntu 18.04. The history entry is no longer displayed when adding a trailing space to the search term.

Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.