Closed Bug 1696444 Opened 9 months ago Closed 9 months ago

The Firefox icon from the task bar is no longer displayed if Firefox is pinned again after it is already pinned

Categories

(Firefox :: Messaging System, defect, P1)

Desktop
Windows 10
defect

Tracking

()

VERIFIED FIXED
88 Branch
Iteration:
88.2 - Mar 8 - Mar 21
Tracking Status
firefox86 --- wontfix
firefox87 --- wontfix
firefox88 --- verified

People

(Reporter: romartin, Assigned: Mardak)

References

(Blocks 1 open bug)

Details

Attachments

(2 files)

Attached image 2021-03-04_17h47_14.gif

[Affected Versions]:

  • Firefox Nightly 88.0a1 (Build ID: 20210304092248)
  • Firefox Beta 87.0b7 (Build ID: 20210302185821)
  • Firefox Release 86.0 (Build ID: 20210222142601)

[Affected Platforms]:

  • Windows 10 Version: 2004 x64
  • Windows 10 Version: 2H20 x64

[Prerequisites]:

  • Have a new Firefox profile created.
  • Have the user.js saved in the profile folder before starting it.

[Steps to reproduce]:

  1. Start the Firefox Browser using the “--first-startup” arg.
  2. Click the “Pin to Taskbar” button.
  3. Click the “Back” browser button.
  4. Click the “Pin to Taskbar” button and observe the Windows TaskBar.

[Expected results]:

  • The Firefox Browser is pinned and the Firefox icon is correctly displayed.

[Actual results]:

  • The Firefox Browser is pinned and the Firefox icon is replaced with a placeholder icon.

[Notes]:

  • This issue might affect users that will be enrolled in future experiments that are based on this feature.
  • Unpinning and pinning again the Firefox will fix the icon.

Hey @Ed,

Can you please take a look at this?

Flags: needinfo?(edilee)

Does the placeholder icon still appear after restarting Windows? Looks like from attachment 9206937 [details] restarting Firefox isn't enough.

Does this only happen if Firefox is already pinned, so only really happens if the user goes back and pins again? At least for the experiment, we assume we target users who wouldn't have Firefox pinned by the installer, but yes the back button does allow the user to run into this.

Flags: needinfo?(edilee) → needinfo?(romartin)

Hey @Ed,

I just verified if the issue is still reproducible after restarting Windows and it is not reproducible. The Firefox icon is correctly displayed after a Windows restart.

Flags: needinfo?(romartin)

Linking an old bug that might be related.

See Also: → 1495295
Assignee: nobody → edilee
Priority: -- → P1
Blocks: 1686284
Iteration: --- → 88.2 - Mar 8 - Mar 21
Pushed by elee@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/29d477a1a826
Pin Firefox only if not already pinned to avoid changing taskbar icon r=andreio
Pushed by elee@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/0899f13f701c
Pin Firefox only if not already pinned to avoid changing taskbar icon r=andreio
Status: NEW → RESOLVED
Closed: 9 months ago
Resolution: --- → FIXED
Target Milestone: --- → 88 Branch
Flags: needinfo?(edilee)

I have verified that the issue is no longer reproducible by following the steps from the description using Firefox Nightly 89.0a1 (Build ID: 20210323214359) and Firefox Beta 88.0b2 (Build ID: 202103231950052) on Windows 10 x64 version 1903, 2004, and 20H2.

Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.