Closed Bug 169650 Opened 18 years ago Closed 18 years ago

Thoughtless HTML authors can disable the context menu

Categories

(SeaMonkey :: General, enhancement)

x86
Linux
enhancement
Not set
normal

Tracking

(Not tracked)

VERIFIED DUPLICATE of bug 86193

People

(Reporter: raz.zbmvyyn.bet, Assigned: asa)

References

()

Details

User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0.0) Gecko/20020623 Debian/1.0.0-0.woody.1
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0.0) Gecko/20020623 Debian/1.0.0-0.woody.1

Context menus are typically regarded as part of an application's user-interface,
not part of a document that an application can work on. Unfortunately, by having
oncontextmenu perform a "return false", a page author is able to hobble an
important part of the Mozilla user interface.

This creates various problems: the one that caught my attention was the
inability to view the source of a framed page in order to diagnose why the
submit button was doing nothing, despite the fact that I appeared to have filled
out the form correctly. Granted, the underlying fault here is the page author's,
but the need to fill out the form led me towards using that other browser on
that other operating system. No amount of enhancement to Mozilla can fix the
harm done by all of the world's clueless HTML-jockeys, but allowing them to
hinder attempts by Mozilla users to continue using Mozilla seems unfortunate.

I'd suggest a configuration option, even a prefs.js-only one if neccessary, to
allow oncontextmenu to be ignored at the user's request.

I'm filing this as a feature request, but perhaps the fact that there is no
workaround qualifies this as a normal bug. More knowlegable moderators can
perhaps sort this out.

Reproducible: Always

Steps to Reproduce:
1. Go to the above URL.
2. Right click anywhere on the page.


Actual Results:  
Nothing happened.

Expected Results:  
Displayed a context menu.

*** This bug has been marked as a duplicate of 86193 ***
Status: UNCONFIRMED → RESOLVED
Closed: 18 years ago
Resolution: --- → DUPLICATE
verifying

reporter (as a workaround) with some extra work it's probably possible to figure
out what the URL of the frame holding the form is. If you could load this frame
separately you might be able to debug.
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.