Closed Bug 1696863 Opened 8 months ago Closed 8 months ago

MessageGenerator output contains bogus CRLF after message parts

Categories

(MailNews Core :: Testing Infrastructure, defect)

defect

Tracking

(thunderbird_esr78 wontfix)

RESOLVED FIXED
88 Branch
Tracking Status
thunderbird_esr78 --- wontfix

People

(Reporter: darktrojan, Assigned: darktrojan)

References

Details

Attachments

(1 file)

A message part should look like this:

----------------CHOPCHOP1
Content-Type: text/plain; charset=ISO-8859-1; format=flowed
Content-Transfer-Encoding: 7bit

Hello David Davol!
----------------CHOPCHOP1

but instead we get this:

----------------CHOPCHOP1
Content-Type: text/plain; charset=ISO-8859-1; format=flowed
Content-Transfer-Encoding: 7bit

Hello David Davol!

----------------CHOPCHOP1

This results in attachments having bogus content at the end, and also because it's a CRLF, *nix platforms like to convert it to LF in some circumstances, so test results vary across platforms.

This fixes the message generator output and the tests that depend on the broken behaviour.

Pushed by geoff@darktrojan.net:
https://hg.mozilla.org/comm-central/rev/4127a04a72f3
Remove bogus CRLF from MessageGenerator output. r=john.bieling

Status: ASSIGNED → RESOLVED
Closed: 8 months ago
Resolution: --- → FIXED
Target Milestone: --- → 88 Branch
Duplicate of this bug: 669290
You need to log in before you can comment on or make changes to this bug.