Closed Bug 1696940 Opened 1 year ago Closed 1 year ago

Uniscribe ScriptBreak crashes with win32k lockdown enabled.

Categories

(Core :: Layout: Text and Fonts, enhancement, P1)

All
Windows
enhancement

Tracking

()

RESOLVED FIXED
88 Branch
Tracking Status
firefox88 --- fixed

People

(Reporter: bobowen, Assigned: bobowen)

References

(Blocks 1 open bug)

Details

Attachments

(1 file)

ScriptBreak is used in nsUniscribeBreaker.cpp and crashes when win32k lockdown is enabled. This problem should go away with the changes in bug 1684927.

In the meantime, I intend to land a patch here that uses the code from nsRuleBreaker.cpp when win32k lockdown is enabled. This will allow testing using the pref without causing this crash, although it will cause some line breaking regressions.

Component: Graphics → Layout: Text and Fonts

This is only intended for testing, because win32k lockdown is disabled by
default for content.

No longer blocks: win32k-lockdown
Pushed by bobowencode@gmail.com:
https://hg.mozilla.org/integration/autoland/rev/d5a14597ca06
Use nsRuleBreaker code in nsUniscribeBreaker when win32k lockdown is enabled. r=jfkthame
Status: ASSIGNED → RESOLVED
Closed: 1 year ago
Resolution: --- → FIXED
Target Milestone: --- → 88 Branch
You need to log in before you can comment on or make changes to this bug.